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Chapter 1. Five Spot Geothermal Production and Injection
(EOS1)

Description

This example is Problem 4 - Five Spot Geothermal Production and Injection (EOS1,
EOS2) described in the TOUGH2 User's Manual [Pruess, Oldenburg, and Moridis,
1999]. This example models a five-spot pattern of injection and production from a geo-
thermal reservoir. Only 1/4 of the reservoir is modeled, since the solution is symmetric,
as shown in Figure 1.1. The mesh uses cells of uniform 50 x 50 m size.

Figure 1.1. Five spot geothermal production and injection model (after [Pruess, Oldenburg,
and Moridis, 1999])

We will solve this example using a porous media assumption for the formation.

Specify the Equation of State (EOS)

To ensure that PetraSim uses EOS1, edit your PetraSim preferences using the Prefer-
ences dialog.

1. On the File menu, click Preferences... .

2. In the Simulator Mode list, select TOUGH.

3. In the Default EOS list, select EOS1.

4. Click OK.

Your preferences have now been updated, but you will need to create a new model or
restart PetraSim before they become active. If you already have a model open, it will
not be affected by the preference change.
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On the File menu, click New.

Create the Model Boundary

To create the boundary for this model, use the Define Model Boundary dialog. The
boundary parameters for this model are shown in Table 1.1.

Table 1.1. Model Boundary Dimensions

Axis Min (m) Max (m)

x 0.0 500.0

y 0.0 500.0

z 0.0 305.0

To create the model boundary

1. On the Model menu, click Define Boundary... (or click on the toolbar).

2. Enter the values from Table 1.1.

3. Click OK to create the model boundary.

The resulting boundary is shown in Figure 1.2. You can rotate, pan, and zoom the
model using the mouse and Shift and Alt keys.

Five Spot Geothermal Pro-
duction and Injection (EOS1)
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Figure 1.2. Boundary of model

Create the Grid

To create the solution grid

1. On the Model menu, click Create Grid... (or click on the toolbar).

2. In the Division Method box, select Regular.

3. In the X Cells box, type 10.

4. In the Y Cells box, type 10.

5. In the Z Cells box, type 1.

6. Click OK to create the grid.

Global Properties

Global properties are those properties that apply to the entire model. In this example,
the only thing we will change is the analysis name. To edit global properties, you use
the Global Properties dialog.

On the Properties menu, click Global Properties... (or click on the toolbar).

Simulation Name

1. In the Global Properties dialog, select the Analysis tab.

2. In the Name box, type Five Spot Production and Injection.

EOS Data

The EOS (Equation of State) tab displays options for the active EOS (EOS1). In this
example, the Water, Non-isothermal option is appropriate, so we do not need to make
any changes.

Click OK to close the Global Properties dialog.

Material Properties

To specify the material properties, use the Material Data dialog. This example re-
quires one material.

1. On the Properties menu, click Materials (or click on the toolbar).

2. In the Name box, type POMED.

Five Spot Geothermal Pro-
duction and Injection (EOS1)
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3. In the Density box, type 2650.0.

4. In the Porosity box, type 0.01.

5. In all three Permeability boxes (X, Y, and Z), type 6e-15.

6. In the Wet Heat Conductivity box, type 2.1.

7. In the Specific Heat box, type 1000.0.

8. Click Apply to save the changes.

In addition to the physical rock parameters, we also need to specify the relative per-
meability and capillary pressure functions for this material. These options can be found
in the Additional Material Data dialog. To open this dialog, click the Relative
Perm... button.

To specify the relative permeability function

1. Select the Relative Perm tab.

2. In the Relative Permeability list, select Corey's Curves.

3. In the Slr box, type 0.3.

4. In the Sgr box, type 0.05.

The default capillary pressure (none) is correct for this example.

Click OK to exit the Advanced Material Data dialog.

Click OK again to save your settings and exit the Material Data dialog.

Initial Conditions

The initial state of each cell in the model must be defined. The Default Initial Condi-
tions dialog is used to define initial conditions that will be applied to the entire model.
You can also specify initial conditions by cell, by region, or by importing the results of
a previous analysis. For any analysis, the specific initial conditions will depend on sev-
eral factors including EOS selection, simulator mode, and the initial state of the simu-
lation.

Correct specification of initial conditions is essential for proper convergence and ob-
taining a correct result. The initial conditions must be physically meaningful. Often
this requires an initial state analysis in which a model is run to obtain initial equilibri-
um conditions before the analysis of interest (geothermal production, VOC spill, etc.)
is run.

To edit global initial conditions, on the Properties menu, click Initial Conditions...

Five Spot Geothermal Pro-
duction and Injection (EOS1)
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(or click on the toolbar).

To set the initial conditions

1. Select the Two-Phase (T, Sg) state option.

2. In the Temperature box, type 300.0.

3. In the Gas Saturation box, type 0.01.

4. Click OK.

Selecting a two-phase initial state with a very small gas saturation is an appropriate
simplification for this geothermal analysis. Since we have only one element in the ver-
tical direction, we have selected a temperature of 300 C as a typical for this reservoir.
The pressure will be calculated to correspond to the small gas saturation. Having all
cells in a two-phase state will also reduce the number of state transitions (two-phase to
single-phase or single-phase to two-phase) that make convergence more difficult.

Define Production Cell

The total injection/production from each five spot pattern is 30 kg/sec. Since we are
using quarter symmetry, the production and injection mass flow rates will be 7.5 kg/
sec. In this analysis, we will define injection and production in specific cells using the
Grid Editor. To open the Grid Editor, on the Model menu, click Edit Grid (or click

on the toolbar).

To define the production cell

1. Using the Selection tool, Right-click on the upper right cell.

2. Click Edit Properties....

3. In the Cell Name box, type Production.

4. Click the Sources/Sinks tab.

5. Under, Production, select the Mass Out checkbox.

6. In the Rate box, type 7.5.

7. Click the Print Options tab.

8. Select the Print Cell Time Dependent Data check box.

9. Click OK to close the Edit Cell Data dialog.

You will now see Production as the cell name and also S and P. The S indicates that
the cell is a source/sink. The P indicates that detailed 2D cell history results plots will
be available for this cell.

Five Spot Geothermal Pro-
duction and Injection (EOS1)
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Define Injection Cell

The procdure to define the injection cell is similar

1. In the Grid Editor, click the Selection tool and then right-click on the lower left
cell.

2. Click Edit Properties....

3. In the Cell Name box, type Injection.

4. Click the Sources/Sinks tab.

5. Under, Injection, select the Water/Steam checkbox.

6. In the Rate box, type 7.5.

7. In the Enthalpy box, type 5.0E5.

8. Click the Print Options tab.

9. Select the Print Cell Time Dependent Data check box.

10. Click OK to close the Edit Cell Data dialog.

The Grid Editor display after both production and injection have been defined is
shown in Figure 1.3.

Five Spot Geothermal Pro-
duction and Injection (EOS1)
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Figure 1.3. Grid Editor after injection and production has been defined

On the File menu, click Close to exit the grid editor.

Solution Controls

We will now define the solution options. Options relating the time step and other solu-
tion controls can be found in the Solution Controls dialog.

To open the Solution Controls dialog, on the Analysis menu, click Solution Con-
trols... (or click on the toolbar).

For this example, we will set the end time and initial time step size.

1. In the End Time box, type 1.15185e9.

2. In the Time Step list, ensure that Single Value is selected.

3. In the Time Step box, type 100.

4. Select Enable Automatic Time Step Adjustment.

Click OK to exit the Solution Controls dialog.

Output Controls

By default, the simulation will print output every 100 time steps. We can increase the
frequency of the output in the Output Controls dialog.

1. On the Analysis menu, click Output Controls... (or click on the toolbar).

2. In the Print and Plot Every # Steps box, type 5.

3. Click OK to exit the Output Controls dialog.

Save and Run

The input is complete and you can run the simulation. If you haven't already, you may
want to save your model in a directory specifically intended for the simulation results.
For example

1. On the File menu, click Save (or click on the toolbar).

2. Create a new folder named Five Spot and in the File Name box, type
five_spot.sim.

3. Click Save.

Five Spot Geothermal Pro-
duction and Injection (EOS1)
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To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

View 3D Results

To view the 3D results for a simulation, on the Results menu, click 3D Results (or
click on the toolbar). The data for the current simulation will be automatically
loaded and displayed.

To show temperature data for the last time step

1. In the Scalar list, select T.

2. In the Time(s) list, select the last entry (1.152E09).

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Z.

2. In the Coord box, type 100.0.

3. Select the Scalar check box.

4. Click Close.

To turn off the isosurfaces, click to clear the Show Isosurfaces check box.

The resulting contour plot is shown in Figure 1.4.

Five Spot Geothermal Pro-
duction and Injection (EOS1)
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Figure 1.4. Temperature contours at end of simulation

On the File menu, click Close to close the 3D Results window

View Cell History Plots

You can view time history plots with the Cell History dialog. On the Results menu,
click Cell History Plots.... (or click on the toolbar).

The Cell History dialog will be displayed. In this window, you can display time his-
tory data using a plotting parameter and a list of cells. For example, to view the tem-
perature in the Injection cell (cell #1)

1. In the Variable list, select T.

2. In the Cell Name (Id#) list, select Injection (#1).

Figure 1.5. Temperature history of injection cell

In the File menu, click Close to close the Cell History window.

Five Spot Geothermal Pro-
duction and Injection (EOS1)
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Chapter 2. 3D Five Spot Geothermal Production and Injection
(EOS1)

Description

This example is a 3D variation of the five-spot example in Chapter 1. In this analysis,
we use a 3D mesh and model the injection and production wells. We model 1/2 of the
repeating five-spot pattern.

In the following descriptions, we use the full menu selection hierarchy. Optionally,
many of the input dialogs can be accessed directly using the toolbar.

Specify the Equation of State (EOS)

To ensure that PetraSim uses EOS1, you may need to edit your PetraSim preferences.
To edit preferences, you can use the Preferences dialog.

1. On the File menu, click Preferences... .

2. In the Simulator Mode list, select TOUGH.

3. In the Default EOS list, select EOS1.

4. Click OK.

Your preferences have now been updated, but you will need to create a new model or
restart PetraSim before they become active. If you already have a model open, it will
not be affected by the preference change.

On the File menu, click New.

Create the Model Boundary

To create the boundary for this model, use the Define Model Boundary dialog. The
boundary parameters for this model are shown in Table 2.1.

Table 2.1. Model Boundary Dimensions

Axis Min (m) Max (m)

x -500.0 500.0

y 0.0 500.0

z -305.0 0.0
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To create the model boundary

1. On the Model menu, click Define Boundary... (or click on the toolbar).

2. Enter the values from Table 1.1.

3. Click OK to create the model boundary.

You can rotate, pan, and zoom the model using the mouse and Shift and Alt keys.

Create the Grid

To create the grid

1. On the Model menu, click Create Grid... (or click on the toolbar).

2. In the Division Method box, select Regular.

3. In the X Cells box, type 21.

4. In the Y Cells box, type 11.

5. In the Z Cells box, type 6.

6. Click OK to create the grid.

Global Properties

Global properties are those properties that apply to the entire model. In this example,
the only thing we will change is the analysis name. To edit global properties, you use
the Global Properties dialog.

On the Properties menu, click Global Properties... (or click on the toolbar).

1. In the Global Properties dialog, select the Analysis tab

2. In the Name box, type 3D Five Spot Production and Injection

Click OK to close the Global Properties dialog.

Material Properties

To specify the material properties, you use the Material Data dialog. This example re-
quires one material.

1. On the Properties menu, click Materials (or click on the toolbar).

2. In the Name box, type POMED.

3D Five Spot Geothermal Pro-
duction and Injection (EOS1)
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3. In the Density box, type 2650.0.

4. In the Porosity box, type 0.01.

5. In all three Permeability boxes (X, Y, and Z), type 6e-15.

6. In the Wet Heat Conductivity box, type 2.1.

7. In the Specific Heat box, type 1000.0.

8. Click Apply to save the changes.

In addition to the physical rock parameters, we also need to specify the relative per-
meability and capillary pressure functions for this material. These options can be found
in the Additional Material Data dialog. To open this dialog, click the Relative
Perm... button.

To specify the relative permeability function

1. Select the Relative Perm tab.

2. In the Relative Permeability list, select Corey's Curves.

3. In the Slr box, type 0.3.

4. In the Sgr box, type 0.05.

The default capillary pressure (none) is correct for this example.

Click OK to exit the Advanced Material Data dialog.

Click OK again to save your settings and exit the Material Data dialog.

Initial Conditions

The initial state of each cell in the model must be defined. To specify global initial
conditions that will be used as the default for all cells in the model, on the Properties
menu, click Initial Conditions... (or click on the toolbar).

To set the initial conditions

1. Select the Two-Phase (T, Sg) state option.

2. In the Temperature box, type 300.0.

3. In the Gas Saturation box, type 0.01.

4. Click OK.

3D Five Spot Geothermal Pro-
duction and Injection (EOS1)
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Define Production Wells

In this model, we will use the well option in PetraSim. This is not a true well model
with flow through cells that represent the well, it is just a way to quickly identify cells
that intersect a well and then create independent sources and sinks in each intersected
cell. This well will be straight, with the geometry coordinates shown in Table 2.2. For
a curved well, you can use more coordinates, but they must be given in order from
either the top or bottom of the well.

Table 2.2. Geometry of the first production well

X (m) Y (m) Z (m)

-475.0 475.0 0.0

-475.0 475.0 -305.0

To create a well, on the Model menu, click Add Well....

1. In the Name box, type ProdUL.

2. In the Coordinates boxes, type the values shown in Table 2.2.

3. Click OK to save the changes.

Now expand the Wells in the Tree View and double-click on ProdUL to define the
flow properties of the well. The completion interval is the length of the well from
which fluid can be produced (or injected) into the reservoir.

1. Click the Geometry tab.

2. In the Top Completion Depth box, type -200.0.

3. In the Bottom Completion Depth box, type -305.0.

The boundary condition options for a well are similar to those for individual cells. The
flow into (or from) each cell intersected by the well can be apportioned either by the
cell intersection length divided by the total completion length or using the permeabil-
ity-length product (k*h). This proportions flow taking into account the different per-
meabilities of the intersected cells. For this model, we will produce at a rate of 7.5 kg/s
from each production well.

1. Click the Flow tab.

2. Select the Mass Out check box.

3. In the Rate box, type 7.5.

3D Five Spot Geothermal Pro-
duction and Injection (EOS1)
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4. Select the Using k*h.

5. Click OK to save the changes.

Create a second production well named ProdUR with the coordinates shown in Ta-
ble 2.3. Use the same completion interval and production rates as for the ProdUL well.

Table 2.3. Geometry of the second production well

X (m) Y (m) Z (m)

475.0 475.0 0.0

475.0 475.0 -305.0

Define Injection Well

We will model one injection well. Create the well using the coordinates in Table 2.4.
Use the name Inject.

Table 2.4. Geometry of the injection well

X (m) Y (m) Z (m)

0.0 25.0 0.0

0.0 25.0 -305.0

Double-click on Inject to define the flow properties of the well. Define the completion
interval.

1. Click the Geometry tab.

2. In the Top Completion Depth box, type 0.0.

3. In the Bottom Completion Depth box, type -200.0.

This is an injection well with a flow rate of 15.0 kg/s.

1. Click the Flow tab.

2. Under Injection, select the Water/Steam check box.

3. In the Rate box, type 15.0.

3D Five Spot Geothermal Pro-
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4. In the Enthalpy box, type 5.0E5. Using a steam table, this corresponds to sub-
cooled water at a temperature of about 119 C.

5. In the Apportion box, select Using k*h.

6. Click OK to save the changes.

A display of the wells is shown in Figure 2.1. To turn off the grid

1. On the View menu, click Grid.

Figure 2.1. Wells in the model

Solution Controls

We will now define the solution options. Options relating the time step and other solu-
tion controls can be found in the Solution Controls dialog.

To open the Solution Controls dialog, on the Analysis menu, click Solution Con-
trols... (or click on the toolbar).

For this example, we will set the end time and the initial time step size.

1. In the End Time box, type 1.15185e9.

2. In the Time Step list, ensure that Single Value is selected.

3D Five Spot Geothermal Pro-
duction and Injection (EOS1)
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3. In the Time Step box, type 100.

4. Select Enable Automatic Time Step Adjustment.

Click OK to exit the Solution Controls dialog.

Output Controls

By default, the simulation will print output every 100 time steps. We can change the
frequency of the output in the Output Controls dialog.

1. On the Analysis menu, click Output Controls... (or click on the toolbar).

2. In the Print and Plot Every # Steps box, type 5.

3. Select the Fluxes and Velocities check box.

4. Click OK to exit the Output Controls dialog.

Save and Run

The input is complete and you can run the simulation. If you haven't already, you may
want to save your model in a directory specifically intended for the simulation results.
For example

1. On the File menu, click Save (or click on the toolbar).

2. Create a new folder named 3D Five Spot Wells and in the File Name box, type
five_spot_wells.sim.

3. Click Save.

To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

View 3D Results

To view the 3D results for a simulation, on the Results menu, click 3D Results (or
click on the toolbar). The data for the current simulation will be automatically
loaded and displayed.

To show temperature data for the last time step

1. In the Time(s) list, select the last entry (1.152E09).

2. In the Scalar list, select T.

To show water flow vectors

3D Five Spot Geothermal Pro-
duction and Injection (EOS1)
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1. In the Vectors list, select FLOF.

2. Select the Show Vectors checkbox.

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Z.

2. In the Coord box, type -200.0.

3. Select the Scalar check box.

4. In the Axis list, select X.

5. In the Coord box, type 0.0.

6. Select the Scalar check box.

7. Click Close.

The resulting contour plot is shown in Figure 2.2.

3D Five Spot Geothermal Pro-
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Figure 2.2. Temperature contours and water flow vectors at end of simulation

On the File menu, click Close to close the 3D Results window.

3D Five Spot Geothermal Pro-
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Chapter 3. 3D Contour Example (EOS1)

Description

This example demonstrates a basic reservoir analysis, including an initial state calcula-
tion and then a production analysis. The example also demonstrates the use of contours
to define the model surface, so that the surface represents a varying topography. Sur-
face boundary conditions are also specified.

It is assumed that the user has obtained familiarity with PetraSim by working the ex-
amples in Chapter 1 and Chapter 2.

Specify the Equation of State (EOS)

To ensure that PetraSim uses EOS1, edit your PetraSim preferences using the Prefer-
ences dialog.

1. On the File menu, click Preferences... .

2. In the Simulator Mode list, select TOUGH.

3. In the Default EOS list, select EOS1.

4. Click OK.

Your preferences have now been updated, but you will need to create a new model or
restart PetraSim before they become active. If you already have a model open, it will
not be affected by the preference change. On the File menu, click New.

Create the Model Boundary

To create the boundary, use the Define Model Boundary dialog. The boundary para-
meters for this model are shown in Table 3.1.

Table 3.1. Model boundary dimensions

Axis Min (m) Max (m)

x -1000.0 1000.0

y 0.0 1000.0

z -1500.0 200.0

To create the model boundary

1. On the Model menu, click Define Boundary... (or click on the toolbar).
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2. Enter the values from Table 3.1.

3. Click OK to create the model boundary.

You can rotate, pan, and zoom the model using the mouse and Shift and Alt keys.

Define Contour of Model

We next define the top contour of the model. This is done using a file that defines the
surface contour levels in the format described in the PetraSim User Manual

To specify the top surface contour

1. Download the contour file for this example under Support at ht-
tp://www.thunderheadeng.com). Save the file with the name top.ctr.

2. On the Model menu, click Set Top and Bottom....

3. In the Top Surface list, click Contour and then click Choose to select the top.ctr
file, Figure 3.1.

4. Click OK to save the data.

Figure 3.1. Defining the top contour of the model

Create the Grid

To create the solution grid

1. On the Model menu, click Create Grid... (or click on the toolbar).

2. In the Division Method box, select Regular.

3. Click Cells Above Top and Below Bottom are Inactive. This removes the cells
outside of the boundaries from the model.

4. Click XYZ Grid.

5. In the X Cells box, type 20.

6. In the Y Cells box, type 10.

3D Contour Example (EOS1)

20

http://www.thunderheadeng.com
http://www.thunderheadeng.com


7. In the Z Cells box, type 17.

8. Click OK to create the grid.

The resulting mesh is displayed in Figure 3.2. Click on the model and spin it so that it
is displayed as shown below. Hold the Shift key and drag to pan; hold the Alt key and
drag to zoom. The display shows the cells that have been disabled as a result of defin-
ing a top contour. This capability allows the user to define more complex surface fea-
tures in detailed models.

Figure 3.2. Creating grid for the model

Global Properties

None of the global properties need to be changed. We use the default EOS1 option of
water, non-isothermal.

Material Properties

To specify the material properties, use the Material Data dialog. This example re-
quires three materials.

1. On the Properties menu, click Materials (or click on the toolbar).

2. In the Name box, type POMED.

3. In the Density box, type 2650.0.

4. In the Porosity box, type 0.01.

3D Contour Example (EOS1)
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5. In all three Permeability boxes (X, Y, and Z), type 6e-15.

6. In the Wet Heat Conductivity box, type 2.1.

7. In the Specific Heat box, type 1000.0.

8. Click Apply to save the changes.

In addition to the physical rock parameters, we can also specify the relative permeabil-
ity and capillary pressure functions by clicking the Relative Perm... button. for this
example, we will just use the default functions and so will not make any changes.

We will now create a new cap rock material, based on POMED

1. In the Material Data dialog, click New.

2. In the Tough Name box, type CAPRK.

3. In the Description box, type Cap Rock.

4. In the Based On list, select POMED.

5. Click OK to create the new material.

The CAPRK will represent a material with low permeability near the top of the reser-
voir. Because it was based on the POMED material, it has inherited all the properties
we previously defined for that material. To modify the CAPRK material

1. On the Materials list, select CAPRK.

2. In all three Permeability boxes (X, Y, and Z), type 6e-16.

3. Click Apply to save the changes.

Finally, we will create one material to be used to represent an aquifer boundary condi-
tion. This material will allow the flow of water, but not heat.

1. In the Material Data dialog, click New.

2. In the Tough Name box, type AQUIF.

3. In the Description box, type Aquifer.

4. In the Based On list, select POMED.

5. Click OK to create the new material.

The AQUIF will represent a material with zero heat conduction. To modify the
AQUIF material

3D Contour Example (EOS1)
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1. On the Materials list, select AQUIF.

2. In the Wet Heat Conductivity box, type 0.0, Figure 3.3.

3. Click OK to save the changes and close the Material Data dialog.

Figure 3.3. Changing the conductivity for the material AQUIF

Initial Conditions

The initial state of each cell in the model must be defined. For this analysis, we will
define linear pressure and temperature gradients. At the surface (200 m), the pressure
will be 1E5 Pa (1 bar) and the temperature 10 C. At the bottom of the reservoir (-1500
m), the pressure will be the approximate hydraulic head 15E6 Pa and a temperature of
200 C. These initial conditions approximate the steady state solution, so they help
speed convergence.

To define the global initial conditions, on the Properties menu, click Initial Condi-
tions... (or click on the toolbar).

To define the pressure gradient

1. Select the Single-Phase (P, T) state option.

2. In the Pressure type list, select Function.

3. In the Edit Linear Function dialog in the A box, type 1.853E6.

4. In the D box, type -8765.0.

To define the temperature gradient

3D Contour Example (EOS1)

23



1. In the Temperature type list, select Function.

2. In the Edit Linear Function dialog in the A box, type 32.353.

3. In the D box, type -0.1117.

4. Click OK to close the Edit Linear Function dialog.

5. Click OK to close the Default Initial Conditions dialog.

The Default Initial Conditions dialog after the functions have been defined is shown
in Figure 3.4.

Figure 3.4. Defining the initial conditions

Grid Operations

Delete Gridlines

We will first delete some gridlines to reduce the number of cells in the solution. To
edit the grid or individual cell properties, use the Grid Editor.

To delete gridlines in the model

1. Open the Grid Editor. On the Model menu, click Edit Grid (or click on the
toolbar).

2. Click on the View icon to select the XZ View.

3. Right-click on the 5th gridline down from the top.

4. Click Delete Selected Line.

5. Repeat for the 7th, 9th, and 11th gridlines from the top.

When completed, the side view should be as shown in Figure 3.5. We leave the more
refined grid to represent the reservoir from -1500 to -1000 m.

3D Contour Example (EOS1)
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Figure 3.5. The view after removing gridlines 5, 7, 9, 11

Insert Gridline

We will also insert a gridline that will give a thin layer of cells on the side of the reser-
voir. These will be used to define boundary conditions. To insert a gridline

1. In the Grid Editor, click on the View icon to select the XZ View.

2. On the Edit menu, click Add Vertical Line....

3. In the Add Vertical Line dialog, in the X Position box, type 990.0.

4. Click OK to close add the line.

The new gridline will be inserted on the right side of the grid.

Change Material Properties of a Layer

We will assign the relatively impermeable material properties to a layer of cells near
the top of the model. To do this

1. In the Grid Editor, click on the View icon to select the XY View.

2. In the Layer box, type 10 and then press the ENTER key.

3. On the Edit menu, click Select Layer (or press and drag the mouse to select all
cells). In the 3D view, the selected layer will be highlighted.

4. Right-click on any of the selected cells and click Properties.

3D Contour Example (EOS1)
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5. In the Material list, select CAPRK.

6. Click OK to close the Edit Multi-Cell Data dialog.

To confirm that the material has been assigned

1. In the Grid Editor, click on the View icon to select the XZ View.

2. In the Property list, select Material.

3. The display will show two materials, Figure 3.6. Note that the material name is
displayed in the lower information bar as the cursor hovers over each cell.

Figure 3.6. Displaying the different materials in different colors

Surface Boundary Conditions

We now want to define surface boundary conditions for the model. These will be a
pressure of 1E5 Pa (1 bar) and a temperature of 10 C.

1. In the Grid Editor, click on the View icon to select the XZ View.

2. In the Layer box, scroll to layer 1.

3. Select the top cells in the layer, Figure 3.7. To select multiple cells, press the
CTRL key and then either drag or click on individual cells.

4. Right-click on any of the selected cells and click Properties.

5. In the Type list, select Fixed State.
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6. Click the Initial Conditions tab.

7. Click Specify Initial Conditions by Cell. The initial conditions for the individual
cells override the global values.

8. In the Pressure box, type 1E5.

9. In the Temperature box, type 10.0.

10. Click OK to close the Edit Multi-Cell Data dialog.

11. You will see an F indicating these cells are Fixed State.

Figure 3.7. Selecting multiple cells to be edited

Repeat this operation for all 10 layers in the XZ View, remembering to select only the
top cells for each layer.

When completed, you can verify your specification by looking at the mesh in different
views. For example, click on the View icon to select the XY View. In the Layer box,
scroll to layer 12. You should see the fixed cells displayed as in Figure 3.8.
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Figure 3.8. The result after changing the top cells in each layer

Define Heat Source

We will assume that there is a heat source at the bottom of the reservoir. To define this
source

1. In the Grid Editor, click on the View icon to select the XY View.

2. In the Layer box, scroll to layer 1.

3. In this view, click and drag to select the cells shown in Figure 3.9. We will define
a total flow of 25 kg/s for these 50 cells, or 0.5 kg/s for each cell.

4. Right-click on any of the selected cells and click Source/Sink....

5. Under Injection, select the Water/Steam check box..

6. In the Rate box, type 0.5.

7. In the Enthalpy box, type 1.085E6.

8. Click OK to close the Edit Multi-Cell Data dialog.

9. You will see an S indicating these cells are Sources.
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Figure 3.9. The cells to select in Layer 1

Define Outflow Aquifer

We will define a fixed pressure aquifer on the side of the reservoir. We previously
defined a mass upflow from the bottom of the reservoir. By setting a fixed pressure on
selected cells on the side of the reservoir, this will represent an aquifer that receives
outflow from the reservoir. We will also change the material type of the aquifer cells to
AQUIF.

1. In the Grid Editor, click on the View icon to select the YZ View.

2. In the Layer box, scroll to layer 21 (or enter 21 and press ENTER.

3. In this view, click and drag to select the cells shown in Figure 3.10.

4. Right-click on any of the selected cells and click Properties.

5. In the Type list, select Disabled.

6. Click OK to close the Edit Multi-Cell Data dialog.

7. The disabled cells will not be drawn.

3D Contour Example (EOS1)
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Figure 3.10. The cells to select for Layer 21

Repeat to disable the cells shown in Figure 3.11

Figure 3.11. The remaining cells to disable

This leaves one line of cells that are still Enabled in Layer 21. We will define a fixed
pressure for these cells.

1. Click and drag to select the cells shown in Figure 3.12.

2. Right-click on any of the selected cells and click Properties.

3D Contour Example (EOS1)
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3. In the Material list, select AQUIF.

4. In the Type list, select Fixed State.

5. Click the Initial Conditions tab.

6. Click Specify Initial Conditions by Cell. The initial conditions for the individual
cells override the global values.

7. In the Pressure box, type 3.5E6. This corresponds to a hydrostatic pressure at
400 m depth. Since the AQUIF material has zero heat conductivity, the temperat-
ure of these cells will not affect heat flow, so we do not change it.

8. Click OK to close the Edit Multi-Cell Data dialog.

Figure 3.12. The remaining cells to be selected

Select Cells for Time History Output

We can select cells to print output more frequently than the frequency for the entire
mesh.

1. In the Grid Editor, go to Layer 1 in the XY View.

2. Right-click on a cell in the center of the heat source and click Edit Properties....

3. In the Name box, type Source.

4. Click the Print Options tab.

5. Select the Print Cell Time Dependent Data check box.
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6. Click OK to close the Edit Cell Data dialog.

Similarly, in Layer 20 of the YZ View, select a cell near the outflow (approximate co-
ordinates Y=450.0, Z=-400.0) for printing. Give it a Name of Outflow and select the
Print Cell Time Dependent Data check box.

Close the grid editor.

Solution Controls

We will now define the solution options.

1. On the Analysis menu, click Solution Controls... (or click on the toolbar).

2. In the End Time box, type 6.308E11 sec (about 20,000 years).

3. In the Time Step list, ensure that Single Value is selected.

4. In the Time Step box, type 100.

5. In the Max Num Time Steps box, type 500.

6. Select Enable Automatic Time Step Adjustment.

7. Click OK to exit the Solution Controls dialog..

Output Controls

By default, the simulation will print output every 100 time steps. We can increase the
frequency of the output in the Output Controls dialog.

1. On the Analysis menu, click Output Controls... (or click on the toolbar).

2. In the Print and Plot Every # Steps box, type 20.

3. Click OK to exit the Output Controls dialog.

Save and Run

The input is complete and you can run the simulation. If you haven't already, you may
want to save your model in a directory specifically intended for the simulation results.
For example

1. On the File menu, click Save (or click on the toolbar).

2. Create a new folder named Initial and in the File Name box, type initial.sim.

3. Click Save.
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To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

During the solution, a graph will display the time step size. In this case, the time steps
become very large near the end of the solution, which indicates that a steady state has
been reached.

View 3D Results

To view the 3D results for a simulation, on the Results menu, click 3D Results (or
click on the toolbar). The data for the current simulation will be automatically
loaded and displayed.

To show temperature contours for the last time step

1. In the Time(s) list, select the last entry (6.308E11).

2. In the Scalar list, select T.

3. Select the Show Isosurfaces checkbox.

To show water flow vectors

1. In the Vectors list, select FLOF.

2. Select the Show Vectors checkbox.

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Y.

2. In the Coord box, type 500.0.

3. Select the Scalar check box.

4. Click Close.

The resulting contour and vector plot is shown in Figure 3.13. The heating upflow and
the cooling downflow can be seen.
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Figure 3.13. The resulting display of the simulation

Close the 3D Results window.

View Cell History Plots

You can view time history plots with the Cell History dialog. On the Results menu,
click Cell History Plots.... (or click on the toolbar).

The Cell History dialog will be displayed. In this window, you can display time his-
tory data using a plotting parameter and a list of cells. For example, to view the tem-
perature in the Outflow cell

1. In the Variable list, select T.

2. In the Cell Name (Id#) list, select Outflow.
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Figure 3.14. Time history plot at Outflow cell

In the File menu, click Close to close the Cell History window.

Production Analysis

We will now use the initial state results to perform a simplified production analysis.
You will open the model file (initial.sim) that we previously saved and then save it to a
new directory.

1. If the initial model is not already open, on the File menu, click Open (or click
on the toolbar). In the File Name box, select the initial.sim file and click Open.
This will open the existing model.

2. To save the production model, on the File menu, click Save As....

3. Create a new folder named Production and in the File Name box, type produc-
tion.sim.

4. Click Save.

Solution Controls for Production Run

This analysis will continue from the initial state analysis.

1. On the Analysis menu, click Solution Controls... (or click on the toolbar).
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2. In the End Time box, type 6.307E8 sec (about 20 years).

3. Click OK to exit the Solution Controls dialog..

Load Initial Conditions

We will now perform a sample production analysis, using the previously calculated
initial state results as initial conditions. We do this by reading the SAVE file that was
output at the end of the initial state analysis. This file has the results for all the cells in
the model. To read these initial conditions

1. On the File menu, click Load Initial Conditions... .

2. Browse to the Initialfolder and select the SAVE file.

3. Click Open. This reads the saved data from the previous run and stores it as an
initial condition for each cell in the current analysis.

To view the initial conditions, open the Grid Editor

1. On the Model menu, click Edit Grid (or click on the toolbar).

2. In the Grid Editor, click on the View icon to select the XZ View.

3. In the Property list, select Temperature.

4. The display will show the temperatures from the initial state analysis, Figure 3.15.

Figure 3.15. The grid editor with temperature as the display variable
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Define Injection and Production

In the production run, we will produce from two wells and inject into one well. The in-
jection and production data will be defined in a separate input file, but the data in the
file uses names that must match cell names. To give the cell names

1. In the Grid Editor, click on the View icon to select the XY View.

2. In the Layer box, scroll to layer 3.

3. Right-click on the cell named P1 as shown in Figure 3.16 and click Properties.

4. In the Cell Name box, enter P1.

5. Click OK to close the Edit Cell Data dialog..

6. Repeat, naming the P2 and I1 cells.

Figure 3.16. The cells to select and name

The well production and injection rates will be read from a file (download the wellt-
able.dat file). The content of this file is shown below.

P1 P2 I1
MASS MASS COM1

0. 10. 0. 0. 0. 0. 0.
3.154E7 10. 0. 10. 0. 15. 4.19E5
3.154E9 10. 0. 10. 0. 15. 4.19E5

The first line gives names of the wells. These names must also be defined as cell
names in the Grid Editor. The second line gives the generation type (MASS for pro-
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duction, COM1 for injection) for each well. The following lines each contain a time
followed by pairs of flow rate and enthalpy for each well. Enthalpy is required, but not
used, for production wells. In the above example, we produce from only P1 for one
year, then begin producing from P2 and injecting in I1 after one year. This table input
is provided so that the user could set up a spreadsheet with all well data. Note: The file
MUST be in this format for it to load correctly.

To load the welltable file

1. Close the Grid Editor.

2. On the File menu, click Load Well Flow Rates.

3. In the File Name box, select the welltable.dat file that you downloaded.

4. Click Open to load the data.

If you now return to the Grid Editor and look at the Source/Sink data for the named
cells, you will find that tables with the specified flow rates have been associated with
each cell.

Save and Run Production Analysis

The input is complete and you can run the simulation. The model file will automatic-
ally be saved when you run the analysis.

To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

View 3D Results for Production Run

To view the 3D results for a simulation, on the Results menu, click 3D Results (or
click on the toolbar). The data for the current simulation will be automatically
loaded and displayed.

To show temperature contours for the last time step

1. In the Time(s) list, select the last entry (6.308E8).

2. In the Scalar list, select T.

3. Click to clear the Show Isosurfaces checkbox. The contours will be displayed on
a slice plane.

To show water flow vectors

1. In the Vectors list, select FLOF.

2. Select the Show Vectors checkbox.
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To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Y.

2. In the Coord box, type 750.0.

3. Select the Scalar check box.

4. Click Close.

The resulting contour and vector plot is shown in Figure 3.17. The cooling near the in-
jection well and the flow of water from the injection well and to the production wells
can be seen.

Figure 3.17. The final display

Close the 3D Results window.

Summary
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This analysis has given a simple example of an initial state run followed by a produc-
tion run.

Reservoir simulation is typically carried out in three phases. The first is initial-state
modeling, in which the pre-exploitation subsurface temperature and pressure condi-
tions are simulated by assigning a set of hydrological and thermal properties to each
grid block and matching the steady-state natural conditions after a simulated time of
several thousand years. Matching of the observed and calculated initial conditions
(such as temperature, pressure, enthalpy, heat flow, etc.) by trial and error provides the
first round calibration of the model. This match is typically achieved by altering the
distribution of hydrologic properties and the location and strengths of fluid sources and
sinks until known or inferred conditions are reproduced by the model within a chosen
tolerance.

The second phase is referred to as history matching, in which the historical behavior of
production wells (rate, pressure, temperature and enthalpy) and injection wells
(generally rate and injection pressure) are matched by trial and error using the model.
Typically, the production history match is obtained by varying the hydrologic paramet-
ers used in the model, particularly storage-related parameters such as porosity, and of-
ten by refining the grid block arrangement in the vicinity of the production or injection
wells and/or refining the relative permeability characteristics. After the history match
is complete, the initial-state model is re-run to ensure that the changes made for history
matching have not significantly affected the model's ability to again reproduce the ini-
tial state reservoir conditions.

The third stage is forecasting. Once the model has been calibrated by initial-state mod-
eling and history matching, it can be considered fully calibrated and used to predict fu-
ture well and reservoir behavior under various production and injection scenarios.
Forecasting is the final stage of numerical modeling of geothermal reservoirs, and is an
indispensable tool for optimizing resource recovery, project planning, mitigating po-
tential development problems, and reservoir management.
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Chapter 4. Heat Sweep in a Vertical Fracture (EOS1)

Description

This example is Problem 3 - Heat Sweep in a Vertical Fracture (EOS1) as described in
the TOUGH2 User's Manual [Pruess, Oldenburg, and Moridis, 1999]. This problem
models non-isothermal injection into and production from a single vertical fracture.

The geometry of the problem is given below. The fracture is bounded by semi-infinite
half spaces of impermeable rock, which provide a conductive heat supply. Initial tem-
perature is 300 C and initial average pressure is 10 MPa (100 bar). Water at 100 C is
injected at a rate of 4 kg/s over the interval from -140 to -160 m on the left side and
water is produced from -60 to -40 m on the right (origin of coordinate system on upper
left corner of fracture). Only the fracture is meshed, a semi-analytical solution is used
for the conduction in the confining layers.

Figure 4.1. The injection-production system in the vertical fracture (after Pruess et al., 1999)

This analysis is run in two segments. The first segment is used to obtain an initial hy-
drostatic pressure profile. In the first segment, there is no heat transfer (isothermal).
The initial conditions include a uniform temperature (300 C) and the average pressure
for the fracture (10 MPa). Since there is no injection or production in this first seg-
ment, the solution will give a hydrostatic profile, with the largest pressure at the bot-
tom of the fracture.

The second segment uses the hydrostatic profile as an initial condition. Injection and
production is initiated in the model and the solution is continued for 1.57788E8 sec
(1,826 days or 5 years). At the end of this time, there is significant cooling throughout
the fracture, especially near the injection point.

Specify the Equation of State (EOS)

41



To ensure that PetraSim uses EOS1, edit your PetraSim preferences using the Prefer-
ences dialog.

1. On the File menu, click Preferences...

2. In the Simulator Mode list, select TOUGH.

3. In the Default EOS list, select EOS1.

4. Click OK.

Your preferences have now been updated, but you will need to create a new model or
restart PetraSim before they become active. If you already have a model open, it will
not be affected by the preference change.

On the File menu, click New.

Create the Model Boundary

To create the boundary for this model, use the Define Model Boundary dialog. The
boundary parameters for this model are shown in Table 4.1.

Table 4.1. Model Boundary Dimensions

Axis Min (m) Max (m)

x 0.0 240.0

y 0.0 0.04

z -200.0 0.0

To create the model boundary

1. On the Model menu, click Define Boundary... (or click on the toolbar).

2. Enter the values from Table 4.1.

3. Click OK to create the model boundary.

4. On the View menu, click Front View (or click on the toolbar).

Create the Grid

To create the grid

1. On the Model menu, click Create Grid... (or click on the toolbar).

Heat Sweep in a Vertical
Fracture (EOS1)
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2. In the Division Method box, select Regular.

3. In the X Cells box, type 12.

4. In the Y Cells box, type 1.

5. In the Z Cells box, type 10.

6. Click OK to create the grid.

The solution grid is shown in Figure 4.2.

Figure 4.2. The solution grid

Global Properties

Global properties are those properties that apply to the entire model. In this example,
we will only change the EOS mode. You can edit global properties with the Global
Properties dialog.

On the Properties menu, click Global Properties... (or click on the toolbar).

1. In the Global Properties dialog, click the EOS tab.

2. Select Single Phase, Isothermal.

3. Click OK save your changes.

Material Properties

Heat Sweep in a Vertical
Fracture (EOS1)
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To specify the material properties, you can use the Material Data dialog. This ex-
ample requires one material.

1. On the Properties menu, click Materials (or click on the toolbar).

2. In the Name box, type FRACT.

3. In the Density box, type 2650.0.

4. In the Porosity box, type 0.5.

5. In all three Permeability boxes (X, Y, and Z), type 200E-12.

6. In the Wet Heat Conductivity box, type 0.0.

7. In the Specific Heat box, type 1000.0.

8. Click OK to save these changes.

Because this analysis is single phase liquid, we do not need to specify relative per-
meability or capillary pressure functions.

Initial Conditions

Correct specification of initial conditions is essential for proper convergence and ob-
taining a correct result. In general, the initial conditions need to physically meaningful.
In this example, this requires an initial state analysis in which we will run a simulation
to obtain initial equilibrium conditions before we run the heat sweep analysis.

To set the initial conditions for all cells

1. Select the Single-Phase (P, T) state option.

2. In the Pressure box, type 10.0E6.

3. In the Temperature box, type 300.0.

4. Click OK.

Solution Controls for Transient Analysis

For the transient analysis, we will specify the end time.

To open the Solution Controls dialog: on the Analysis menu, click Solution Con-
trols... (or click on the toolbar).

To change the time step settings

1. In the Solution Controls dialog, click the Times tab.

Heat Sweep in a Vertical
Fracture (EOS1)
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2. In the End Time list, select User Defined and type 1.57788E8 in the box.

3. In the Max Num Time Steps box, type 500.

Click OK to save your changes and exit the Solution Controls dialog.

Save and Run

The input is complete and you can run the simulation. The changes you have made will
automatically be saved before execution.

To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

View Transient Results

To view the 3D transient results

1. On the Results menu, click 3D Results (or click on the toolbar). The data for
the current simulation will be automatically loaded and displayed.

To show pressure contours for the last time step

1. In the Time(s) list, select the only entry (1.3107E7).

2. In the Scalar list, select P (Pa).

3. Click to clear the Show Isosurfaces checkbox.

To view the fracture plane, on the View menu, click Front View (or click on the
toolbar).

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Y.

2. In the Coord box, type 0.02.

3. Select the Scalar check box.

4. Click Close.

The resulting contour plot is shown in Figure 4.3.

Heat Sweep in a Vertical
Fracture (EOS1)
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Figure 4.3. Pressure contours

Close the 3D Results window.

Begin Transient Analysis

We are now ready to begin the second segement of the simulation. When running
multi-part simulations it is best to save your PetraSim model to a different folder to
prevent accidental overwriting of the data from earlier steps.

To save your model to a different folder

1. If the initial model is not already open, on the File menu, click Open (or click
on the toolbar). In the File Name box, select the heat_sweep.sim file and click
Open. This will open the existing model.

2. To save the transient model, on the File menu, click Save As....

3. Create a new folder named Transient and in the File Name box, type
heat_sweep_transient.sim.

4. Click Save.

Load Initial Conditions

Heat Sweep in a Vertical
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We will now perform a transient analysis, using the previously calculated hydrostatic
state results as initial conditions. We do this by reading the SAVE file that was output
at the end of the hydrostatic analysis. This file has the results for all the cells in the
model. To read these initial conditions

1. On the File menu, click Load Initial Conditions... .

2. Browse to the Heat Sweepfolder and select the SAVE file.

3. Click Open. This reads the saved data from the previous run and stores it as an
initial condition for each cell in the current analysis.

To view the initial conditions, open the Grid Editor

1. On the Model menu, click Edit Grid (or click on the toolbar).

2. In the Grid Editor, click on the View icon to select the XZ View.

3. In the Property list, select Pressure.

4. The display will show the pressures from the initial state analysis, Figure 4.4.

Figure 4.4. The grid editor with pressure as the display variable

Define Injection and Production

In the transient analysis, we will inject cold fluid and produce hot fluid from the frac-
ture. We define the injection and production in the Grid Editor.

To define the injection

Heat Sweep in a Vertical
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1. In the Grid Editor, click on the View icon to select the XZ View.

2. Right-click on the third cell up from the lower left corner and click Edit Proper-
ties. The Cell ID should be 25.

3. In the Cell Name box, enter Injection.

4. Click the Sources/Sinks tab.

5. In the Injection section, select the Water/Steam check box.

6. In the Rate box, type 4.

7. In the Enthalpy box, type 4.2E5.

8. Click the Print Options tab.

9. Select the Print Cell Time Dependent Data check box.

10. Click OK to close the Edit Cell Data dialog. You will see the name of the cell
and an "S" to indicate a source and a "P" to indicate time history printing.

To define the production

1. Right-click on the third cell down from the upper right corner and click Edit
Properties. The Cell ID should be 96.

2. In the Cell Name box, enter Production.

3. Click the Sources/Sinks tab.

4. In the Production section, select the Well on Deliv. check box.

5. In the Productivity Index box, type 4.0E-12.

6. In the Pressure box, type 9.65E6.

7. Click the Print Options tab.

8. Select the Print Cell Time Dependent Data check box.

9. Click OK to close the Edit Cell Data dialog. You will see the name of the cell
and an "S" to indicate a source and a "P" to indicate time history printing.

Global Properties for Transient Analysis

The transient analysis is non-isothermal.

On the Properties menu, click Global Properties... (or click on the toolbar).

Heat Sweep in a Vertical
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1. In the Global Properties dialog, click the EOS tab.

2. Select Water, Non-Isothermal.

3. Click OK save your changes.

Confining Bed Boundary Conditions for Transient Analysis

In the transient analysis, heat is conducted to the confining beds on either side of the
fracture. To define this boundary condition, on the Properties menu, click Boundary
Conditions....

1. Select the Enable Heat Exchange with Confining Beds checkbox.

2. In the Initial Temperature box, type 300.0.

3. In the Specific Heat box, type 1000.

4. In the Thermal Conductivity box, type 2.1.

5. In the Density box, type 2650.0.

6. Click OK to save your changes.

Output Controls for Transient Analysis

By default, the simulation will print output every 100 time steps. We can increase the
frequency of the output in the Output Controls dialog.

1. On the Analysis menu, click Output Controls... (or click on the toolbar).

2. In the Print and Plot Every # Steps box, type 10.

3. Click OK to exit the Output Controls dialog.

Save and Run Transient Analysis

The input is complete and you can run the simulation. The model file will automatic-
ally be saved when you run the analysis.

To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

View 3D Results for Transient Analysis

To view the 3D results, on the Results menu, click 3D Results (or click on the tool-
bar). The data for the current simulation will be automatically loaded and displayed.

To show temperature contours for the last time step

Heat Sweep in a Vertical
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1. In the Time(s) list, select the last entry (1.578E8).

2. In the Scalar list, select T (deg C).

3. Click to clear the Show Isosurfaces checkbox. The contours will be displayed on
a slice plane.

To show heat flow vectors

1. In the Vectors list, select FLOH.

2. Select the Show Vectors checkbox.

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Y.

2. In the Coord box, type 0.02.

3. Select the Scalar check box.

4. Click Close.

The resulting contour and vector plot is shown in Figure 4.5. The cooling near the in-
jection well and the flow of water from the injection well and to the production wells
can be seen.

Heat Sweep in a Vertical
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Figure 4.5. The final display

Close the 3D Results window.

View Cell History Plots

You can view time history plots with the Cell History dialog. On the Results menu,
click Cell History Plots.... (or click on the toolbar).

The Cell History dialog will be displayed. In this window, you can display time his-
tory data using a plotting parameter and a list of cells. For example, to view the tem-
perature in the Production cell

1. In the Variable list, select T (deg C).

2. In the Cell Name (Id#) list, select Production.

Heat Sweep in a Vertical
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Figure 4.6. Time history plot at production cell

The user can also write this data to a file. On the File menu, click Export Data..... The
data can then be imported in to another program for display. A plot of the same tem-
perature data in Excel using a logarithmic X-axis is shown in Figure 4.7. This illus-
trates that the result is the same as reported in the TOUGH2 User's Manual.

Figure 4.7. Excel graph of the temperature data

In the File menu, click Close to close the Cell History window.
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Line Plots

PetraSim also supports line plots, where you define a line in 3D space and the data is
interpolated along the line. To make a line plot

1. First open the 3D results view. On the Results menu, click 3D Results (or click
on the toolbar).

2. On the File menu, click Line Plot....

3. In the Point 1 coordinate boxes (X, Y, and Z) type 240.0, 0.02, and -200.0,
respectively.

4. In the Point 2 coordinate boxes (X, Y, and Z) type 240.0, 0.02, and 0.0, re-
spectively.

5. Click OK to close the Line Plot dialog.

6. This will open a Line Plot window.

7. In the Time list, select 1.578E8 (the last time).

8. In the Variable list, select T (Deg C).

The plot is shown in Figure 4.8. You can export this data to a comma separated value
file for import into a spreadsheet.

Figure 4.8. Time history plot at production cell
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Close the Line Plot window.

Heat Sweep in a Vertical
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Chapter 5. Heat Pipe in Cylindrical Geometry (EOS3)

Description

This example is Problem 2 - Heat Pipe in Cylindrical Geometry (EOS3, EOS4) de-
scribed in the TOUGH2 User's Manual [Pruess, Oldenburg, and Moridis, 1999]. Heat
pipes are systems in which an efficient heat transfer takes place by means of a liquid-
vapor counterflow process, with vaporization and condensation occurring at the hot
and cold ends. Heat pipe processes can occur in geothermal reservoirs and storage of
heat-generating nuclear waste packages. This problem represents a simplified model of
nuclear waste emplacement. A cylindrical heater with 0.3 m radius and 4.5 m height
provides a constant heat input of 3 kW into a porous medium with uniform initial con-
ditions of 18 C, 1 bar pressure (1E5 Pa), and 20% gas saturation.

The model uses a 1D radial grid of 200 elements extending to 10,000 m, so that bound-
ary effects are not important. An alternate model, that gives essentially identical res-
ults, can be created using a radius of only 100 m, but with a fixed-state cell at the outer
radius. This is because the solution only changes within a radius of about 50 m.

Figure 5.1. Heat Pipe in Cylindrical Geometry Model

EOS3 Specification

This example uses EOS3. The default EOS is EOS1. To change to EOS3

1. On the File menu, click Preferences... .

2. In the Simulator Mode list, select TOUGH.

3. In the Default EOS list, select EOS3.

4. Click OK.

Your preferences have now been updated, but you will need to create a new model or
restart PetraSim before they become active. If you already have a model open, it will
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not be affected by the preference change. On the File menu, click New.

Create the Model Boundary

To create the boundary, use the Define Model Boundary dialog. The boundary para-
meters for this model are shown in Table 5.1.

Table 5.1. Model boundary dimensions

Axis Min (m) Max (m)

x 0.0 10000.0

y 0.0 1.0

z 0.0 4.5

To create the model boundary

1. On the Model menu, click Define Boundary... (or click on the toolbar).

2. Enter the values from Table 5.1.

3. Click OK to create the model boundary.

Because this model has a very large radius, we will need to scale the dimension in the
Z direction in order to manipulate the model. To do this

1. On the View menu, click Scale Axis....

2. In the Z Factor box, type 1000.

3. Click OK to close the Scale Axis dialog.

You can rotate, pan, and zoom the model using the mouse and Shift and Alt keys.

Create the Grid

To create the solution grid

1. On the Model menu, click Create Grid... (or click on the toolbar).

2. In the Division Method box, select Regular.

3. Click Cells Above Top and Below Bottom are Inactive.

4. Click RZ Grid. This creates a 2D cylindrical grid. It will be displayed as a plane,

Heat Pipe in Cylindrical Geo-
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but when the solution data is written, the volume and connections for the cells
will be calculated in cylindrical coordinates.

5. In the X Cells box, type 200.

6. In the X Factor box, type 1.0361057. This value was calculated to give a cell
size of 0.3 m for the first cell. See the PetraSim User Manual for instructions on
how to do this calculation.

7. In the Z Cells box, type 1.

8. In the Z Factor box, type 1.0.

9. Click OK to create the grid.

The resulting mesh is displayed in Figure 5.2. Click on the model and spin it so that it
is displayed as shown below.

Figure 5.2. The resulting mesh

Global Properties

Global properties are those properties that apply to the entire model. We will make
changes to some of the EOS options, including activating molecular diffusion. To edit
global properties, you use the Global Properties dialog.

On the Properties menu, click Global Properties... (or click on the toolbar).

1. In the Global Properties dialog, select the EOS tab.

Heat Pipe in Cylindrical Geo-
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2. Select Non-Isothermal.

3. Select the Molecular Diffusion checkbox.

4. Click Edit COEFs....

5. On the Edit Coefficients dialog, enter the values given in Table 5.2.

6. Click OK to close the Edit Coefficients dialog.

7. To be consistent with the TOUGH2 manual description, select Tough Style for
the Initialization options.

8. Click OK to close the Tough Global Data dialog.

Table 5.2. Diffusion coefficients

Gas Liquid

Water 2.13E-5 0.0

Air 2.13E-5 0.0

Material Properties

To specify the material properties, you use the Material Data dialog. This example re-
quires one material.

1. On the Properties menu, click Materials (or click on the toolbar).

2. In the Name box, type POMED.

3. In the Density box, type 2550.0.

4. In the Porosity box, type 0.01.

5. In all three Permeability boxes (X, Y, and Z), type 20.e-15.

6. In the Wet Heat Conductivity box, type 2.0.

7. In the Specific Heat box, type 800.0.

8. Click Apply to save the changes.

In addition to the physical rock parameters, we also need to specify the relative per-
meability and capillary pressure functions for this material. These options can be found
in the Additional Material Data dialog. To open this dialog, click the Relative
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Perm... button.

To specify the relative permeability function

1. Select the Relative Perm tab.

2. In the Relative Permeability list, select van Genuchten-Mualem Model.

3. In the Lambda box, type 0.45.

4. In the Slr box, type 9.6E-4.

5. In the Sls box, type 1.0.

6. In the Sgr box, type 0.0.

To specify the capillary pressure function

1. Select the Capillary Press tab.

2. In the Capillary Pressure list, select van Genuchten Function.

3. In the Lambda box, type 0.45.

4. In the Slr box, type 1.0E-3.

5. In the 1/P0 box, type 8.0E-5.

6. In the Pmax box, type 5.0E8.

7. In the Sls box, type 1.0.

To specify the tortuosity

1. Select the Misc tab.

2. In the Tortuosity Factor box, type 0.25.

Click OK to exit the Advanced Material Data dialog.

Click OK again to save your settings and exit the Material Data dialog.

Initial Conditions

The initial state of each cell in the model must be defined. To specify global initial
conditions that will be used as the default for all cells in the model, on the Properties
menu, click Initial Conditions... (or click on the toolbar).

To set the initial conditions
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1. Select the Single-Phase (P, X, T) state option.

2. In the Pressure box, type 1.0E5.

3. In the Temperature box, type 18.0.

4. In the Air Mass Fraction box, type 0.2.

5. Click OK.

Define Heat Source

This model has a heat source at the center. This is defined in the Grid Editor.

To open the Grid Editor, on the Model menu, click Edit Grid (or click on the tool-
bar).

1. In the Grid Editor, click on the View icon to select the XZ View.

2. On the View menu, click Scale Axis....

3. In the Z Factor box, type 1000.

4. Using the Zoom Box tool, zoom in to the top left of the model until you can see
the first cell.

5. Using the Selection tool, right-click on the first cell and click Edit Properties...,
Figure 5.3.

6. In the Cell Name box, type Heat Source.

7. Click the Sources/Sinks tab.

8. In the Heat section, select the Heat In check box.

9. In the Rate box, type 3000.

10. Click the Print Options tab.

11. Select the Print Cell Time Dependent Data check box.

12. Click OK to close the Edit Cell Data dialog.
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Figure 5.3. Select the left cell in the model

Close the Grid Editor.

Solution Controls

We will now define the solution control options.

1. On the Analysis menu, click Solution Controls... (or click on the toolbar).

2. In the End Time box, type 3.155E8.

3. In the Time Step list, ensure that Single Value is selected.

4. In the Time Step box, type 100. This is the initial time step.

5. In the Max Num Time Steps box, type 1000.

6. Select Enable Automatic Time Step Adjustment.

7. Click OK to exit the Solution Controls dialog..

Output Controls

By default, the simulation will print output every 100 time steps. We can increase the
frequency of the output in the Output Controls dialog.

1. On the Analysis menu, click Output Controls... (or click on the toolbar).

2. In the Print and Plot Every # Steps box, type 50.
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3. Click OK to exit the Output Controls dialog.

Save and Run

The input is complete and you can run the simulation. If you haven't already, you may
want to save your model in a new directory. For example

1. On the File menu, click Save (or click on the toolbar).

2. Create a new folder named Heat Pipe and in the File Name box, type
heat_pipe.sim.

3. Click Save.

To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

During the solution, a graph will display the time step size. In this case, the time steps
become very large near the end of the solution, which indicates that a steady state has
been reached.

View 3D Results

To view the 3D results for a simulation, on the Results menu, click 3D Results (or
click on the toolbar). The data for the current simulation will be automatically
loaded and displayed.

Since the model has a large radius relative to its height, we scale the Z coordinates.

1. On the View menu, click Scale Axes....

2. In the Z Factor box, type 1000.

To show temperature contours for the last time step

1. In the Time(s) list, select the last entry (3.155E8).

2. In the Scalar list, select T.

3. Click to clear the Show Isosurfaces checkbox.

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Y.

2. In the Coord box, type 0.5.

3. Select the Scalar check box.
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4. Click Close.

To turn on the mesh to help with distance orientation

1. On the View menu, click Show Grid .

After zooming in on the upper left corner of the model, the resulting contour plot is
shown in Figure 5.4.

Figure 5.4. The resulting display

Close the 3D Results window.

Time History Plots

You can view time history plots with the Cell History dialog. On the Results menu,
click Cell History Plots.... (or click on the toolbar).

The Cell History dialog will be displayed. In this window, you can display time his-
tory data using a plotting parameter and a list of cells. For example, to view the tem-
perature in the Heat Source cell

1. In the Variable list, select T.

2. In the Cell Name (Id#) list, select Heat Source.
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Figure 5.5. Cell history plot of temperature for cell #1

In the File menu, click Close to close the Cell History window.

Line Plots

PetraSim also supports line plots, where you define a line in 3D space and the data is
interpolated along the line. To make a line plot

1. First open the 3D results view. On the Results menu, click 3D Results (or click
on the toolbar).

2. On the File menu, click Line Plot....

3. In the Point 1 coordinate boxes (X, Y, and Z) type 0.0, 0.5, and 0.5, respect-
ively.

4. In the Point 2 coordinate boxes (X, Y, and Z) type 100.0, 0.5, and 0.5, re-
spectively.

5. Click OK to close the Line Plot dialog.

6. This will open a Line Plot window.

7. In the Variable list, select T (deg C).

8. In the Time list, select 3.155E8 (the last time).

The plot is shown in Figure 5.6. You can export this data to a comma separated value
file for import into a spreadsheet.
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Figure 5.6. Line plot of temperature

Close the Line Plot window.

Figure 5.7. and Figure 5.8. display the results in a format that can be compared to the
plot in the TOUGH2 User's Manual. These were made in Excel by exporting line plot
data. Based on these displays, the present results are the same as given in the manual.

Figure 5.7. Results at the end time as a function of radius
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Figure 5.8. Results at the end time as a function of solution variable Z
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Chapter 6. Production from a Geothermal Reservoir (EWASG)

Description

This example is Problem 12 - Production from a Geothermal Reservoir with Hyper-
saline Brine and CO2 (EWASG) described in the TOUGH2 User's Manual [Pruess,
Oldenburg, and Moridis, 1999]. This problem examines production from a hypothetic-
al geothermal reservoir with high salinity and CO2. Fluid withdrawal causes pressure
to drop near the production well. Boiling of reservoir fluid gives rise to dilution of
CO2 in the gas phase and to increased concentrations of dissolved NaCl, which begins
to precipitate when the aqueous solubility limit is reached. As the boiling front receded
from the well, solid precipitate fills approximately 10% of the original void space,
causing permeability to decline to approximately 28% of its original value.

The mesh uses a 1D radial geometry.

EWASG Specification

This example uses EWASG. The default EOS is EOS1. To change to EWASG

1. On the File menu, click Preferences... .

2. In the Simulator Mode list, select TOUGH.

3. In the Default EOS list, select EWASG.

4. Click OK.

Your preferences have now been updated, but you will need to create a new model or
restart PetraSim before they become active. If you already have a model open, it will
not be affected by the preference change. On the File menu, click New.

Create the Model Boundary

To create the boundary for this model, use the Define Model Boundary dialog. The
boundary parameters for this model are shown in Table 6.1.

Table 6.1. Model boundary dimensions

Axis Min (m) Max (m)

X 5.0 1000.0

Y 0.0 1.0

Z -500.0 0.0

67



To create the model boundary

1. On the Model menu, click Define Boundary... (or click on the toolbar).

2. Enter the values from Table 6.1.

3. Click OK to create the model boundary.

You can rotate, pan, and zoom the model using the mouse and Shift and Alt keys.

Create the Grid

To create the solution grid

1. On the Model menu, click Create Grid... (or click on the toolbar).

2. In the Division Method box, select Regular.

3. Click Cells Above Top and Below Bottom are Inactive.

4. Click RZ Grid. This creates a grid a 2D cylindrical grid. It will be displayed as a
plane, but when the solution data is written, the volume and connections for the
cells will be calculated in cylindrical coordinates.

5. In the X Cells box, type 100.

6. In the X Factor box, type 1.03705.

7. In the Z Cells box, type 1.

8. In the Z Factor box, type 1.0.

9. Click OK to create the grid.

We have selected RZ Grid as the grid type. This means that a 2D cylindrical RZ grid
will be created in which X corresponds to cylindrical R, Z corresponds to cylindrical Z,
and the Y coordinate corresponds to cylindrical Theta (which is not used). 100 cells
extend in the R direction, with an X Factor of 1.03705. This means that each cell is
1.03705 times the size of the previous cell in the R direction. These were chosen to
give a first cell length of 2.0 m, which is the value used in the TOUGH2 example. See
the PetraSim User Manual for instructions on how to calculate the appropriate factor.

The resulting mesh is displayed in Figure 6.1. Click on the model and spin it so that it
is displayed as shown below.

Production from a Geotherm-
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Figure 6.1. The resulting model

Global Properties

Global properties are those properties that apply to the entire model. We will make
changes to some of the EOS options, including activating molecular diffusion. To edit
global properties, you use the Global Properties dialog.

On the Properties menu, click Global Properties... (or click on the toolbar).

1. In the Global Properties dialog, select the Analysis tab.

2. In the Name box, type Geothermal Production, Brine and CO2.

1. In the Global Properties dialog, select the EOS tab.

2. Select Non-Isothermal.

3. In the Type of NCG list, select CO2.

4. Click Tubes in Series.

5. In the phi box, type 0.8.

6. In the G box, type 0.8.

7. In the Property Dependence on Salinity list, select Full Dependence.

8. In the Brine Enthalpy Correcton list, select Michaelides.

9. Select the Include Vapor Pressure Lowering checkbox.
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10. Do NOT select Molecular Diffusion.

11. Click OK to close the Global Properties dialog.

Material Properties

To specify the material properties, use the Material Data dialog.

1. On the Properties menu, click Materials (or click on the toolbar).

2. In the Name box, type POMED.

3. In the Density box, type 2600.0.

4. In the Porosity box, type 0.05.

5. In all three Permeability boxes (X, Y, and Z), type 50e-15.

6. In the Wet Heat Conductivity box, type 2.0.

7. In the Specific Heat box, type 1000.0.

8. Click Apply to save the changes.

In addition to the physical rock parameters, we also need to specify the relative per-
meability and capillary pressure functions for this material. These options can be found
in the Additional Material Data dialog. To open this dialog, click the Relative
Perm... button.

To specify the relative permeability function

1. Select the Relative Perm tab.

2. In the Relative Permeability list, select Corey's Curves.

3. In the Slr box, type 0.3.

4. In the Sgr box, type 0.05.

The default capillary pressure (none) is correct for this example.

Click OK to exit the Advanced Material Data dialog.

Click OK again to save your settings and exit the Material Data dialog.

Initial Conditions

The initial state of each cell in the model must be defined. To specify global initial
conditions that will be used as the default for all cells in the model, on the Properties
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menu, click Initial Conditions... (or click on the toolbar).

To set the initial conditions

1. Select the Two Fluid Phases (P, Xsm, Sg, T) state option.

2. In the Pressure box, type 6.0E6.

3. In the Temperature box, type 275.55.

4. In the Gas Saturation box, type 0.45.

5. In the Salt Mass Fraction box, type 0.3.

6. Click OK to close the Default Initial Conditions dialog.

Define Heat Source

In this model, fluid is produced from the inner cell. This is defined in the Grid Editor.

To open the Grid Editor, on the Model menu, click Edit Grid (or click on the tool-
bar).

1. In the Grid Editor, click on the View icon to select the XZ View.

2. Using the Zoom Box tool, zoom in to the top left of the model until you can see
the first cell.

3. Using the Selection tool, right-click on the first cell and click Edit Properties...,
Figure 6.2.

4. In the Cell Name box, type Production.

5. Click the Sources/Sinks tab.

6. In the Production section, select the Mass Out check box.

7. In the Rate box, type 65.

8. Click the Print Options tab.

9. Select the Print Cell Time Dependent Data check box.

10. Click OK to close the Edit Cell Data dialog.

Production from a Geotherm-
al Reservoir (EWASG)

71



Figure 6.2. The cell to be selected

Close the Grid Editor.

Solution Controls

We will now define the solution control options.

1. On the Analysis menu, click Solution Controls... (or click on the toolbar).

2. In the End Time box, type 2.0E6 sec (approximately 23 days).

3. In the Time Step list, ensure that Single Value is selected.

4. In the Time Step box, type 1000. This is the initial time step.

5. Select Enable Automatic Time Step Adjustment.

6. Click OK to exit the Solution Controls dialog..

Output Controls

By default, the simulation will print output every 100 time steps. We can increase the
frequency of the output in the Output Controls dialog.

1. On the Analysis menu, click Output Controls... (or click on the toolbar).

2. In the Print and Plot Every # Steps box, type 10.

3. Click Edit.
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4. In the Addtional Print Times table, type .50E5. This will force a solution prin-
tout at this time.

5. Click OK to exit the Additional Print Times dialog.

6. Click OK to exit the Output Controls dialog.

Save and Run

The input is complete and you can run the simulation. If you haven't already, you may
want to save your model in a new directory. For example

1. On the File menu, click Save (or click on the toolbar).

2. Create a new folder named Geothermal and in the File Name box, type geo-
thermal.sim.

3. Click Save.

To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

During the solution, a graph will display the time step size.

View 3D Results

To view the 3D results for a simulation, on the Results menu, click 3D Results (or
click on the toolbar). The data for the current simulation will be automatically
loaded and displayed.

To show gas saturation contours for the last time step

1. In the Time(s) list, select the last entry (2.0E6).

2. In the Scalar list, select SG.

3. Click to clear the Show Isosurfaces checkbox.

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Y.

2. In the Coord box, type 0.5.

3. Select the Scalar check box.

4. Click Close.
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To turn on the mesh to help with distance orientation

1. On the View menu, click Show Grid .

After zooming in on the upper left corner of the model, the resulting contour plot is
shown in Figure 6.3.

Figure 6.3. 3D representation of the saturation of gas

Close the 3D Results window.

View Cell History Plots

You can view time history plots with the Cell History dialog. On the Results menu,
click Cell History Plots.... (or click on the toolbar).

The Cell History dialog will be displayed. In this window, you can display time his-
tory data using a plotting parameter and a list of cells. For example, to view the gas
saturation in the Heat Source cell
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1. In the Variable list, select SG.

2. In the Cell Name list, select Production.

Figure 6.4 shows the time history plot of SG at the production cell. The user can export
this data for plotting in spreadsheets.

Figure 6.4. The cell history plot for gas saturation in the production cell

Close the Cell History window.

Line Plots

PetraSim also supports line plots, where you define a line in 3D space and the data is
interpolated along the line. To make a line plot

1. First open the 3D results view. On the Results menu, click 3D Results (or click
on the toolbar).

2. On the File menu, click Line Plot....

3. In the Point 1 coordinate boxes (X, Y, and Z) type 5.0, 0.5, and -250.0, re-
spectively.

4. In the Point 2 coordinate boxes (X, Y, and Z) type 1000.0, 0.5, and -250.0,
respectively.

5. Click OK to close the Line Plot dialog.
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6. This will open a Line Plot window.

7. In the Variable list, select P (Pa).

8. In the Time list, select 2000000. (the last time).

The plot is shown in Figure 6.5. You can export this data to a comma separated value
file for import into a spreadsheet.

Figure 6.5. Line plot of pressure

Close the Line Plot window.

Data saved using the line plot are shown in the same format as in the TOUGH2 user's
manual in Figure 6.6. The calculated results compare well with the manual results.
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Figure 6.6.
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Chapter 7. VOC Contamination (TOUGH2 Problem 8)

Problem Description

This example uses EOS7R to simulate the diffusive and advective spreading of volatile
organic contaminants (VOCs) in the vados zone, and their migration across the capil-
lary fringe region into an underlying aquifer. Figure 7.1 shows a schematic of the sys-
tem. The problem is run in two parts: first a solution is made to define the initial grav-
ity/capillary equilibrium, then a transient solution is run with VOC diffusion.

Figure 7.1. Model system for examining migration of VOC from the vados zone into an
aquifer

This problem also demonstrates the use of "extra cells" to define cells that are created
by editing a table and are not created as part of the geometric mesh.

This analysis uses the radionuclides in EOS7R to represent the two VOCs. The radio-
nuclides are considered water-soluble as well as volatile, but are not allowed to form a
separate non-aqueous phase. Volatile and water soluble organic chemicals are modeled
by setting the half life to very large values.

Specify the Equation of State (EOS)

To ensure that PetraSim uses EOS7R, edit your PetraSim preferences using the Prefer-
ences dialog.

1. On the File menu, click Preferences... .

2. In the Simulator Mode list, select TOUGH.

3. In the Default EOS list, select EOS7R.

4. Click OK.
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Your preferences have now been updated, but you will need to create a new model or
restart PetraSim before they become active. If you already have a model open, it will
not be affected by the preference change. On the File menu, click New.

Create the Model Boundary

To create the boundary, use the Define Model Boundary dialog. The boundary para-
meters for this model are shown in Table 3.1.

Table 7.1. Model boundary dimensions

Axis Min (m) Max (m)

x 0.0 1.0

y 0.0 1.0

z -15.0 0.0

To create the model boundary, which extends 15.0 m below the surface

1. On the Model menu, click Define Boundary... (or click on the toolbar).

2. Enter the values from Table 7.1.

3. Click OK to create the model boundary.

You can rotate, pan, and zoom the model using the mouse and Shift and Alt keys.

Create the Grid

To create the solution grid

1. On the Model menu, click Create Grid... (or click on the toolbar).

2. In the Division Method box, select Regular.

3. Click Cells Above Top and Below Bottom are Inactive.

4. Click XYZ Grid.

5. In the X Cells box, type 1.

6. In the Y Cells box, type 1.

7. In the Z Cells box, type 15.
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8. Click OK to create the grid.

The resulting mesh is displayed in Figure 7.2. Click on the model and spin it so that it
is displayed as shown below. Hold the Shift key and drag to pan; hold the Alt key and
drag to zoom.

Figure 7.2. The geometric grid

Global Properties

Global properties are those properties that apply to the entire model. We will make
changes to some of the EOS options, including activating molecular diffusion. To edit
global properties, you use the Global Properties dialog.

On the Properties menu, click Global Properties... (or click on the toolbar).

1. In the Global Properties dialog, select the EOS tab.

2. Select Isothermal.

3. Select the Molecular Diffusion checkbox.

4. Click Edit COEFs....

5. On the Edit Coefficients dialog, enter the values given in Table 7.2.

6. Click OK to close the Edit Coefficients dialog.

7. In the Brine Data list, select Same as Water.
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8. In the Radionuclide Data box, click Edit.

9. To define properties for the Parent Radionuclide Data, enter the values given in
Table 7.3.

10. To define properties for the Daughter Radionuclide Data, enter the values given
in Table 7.4.

11. Click OK to close the Radionuclide Properties dialog.

12. Click OK to close the Global Properties dialog.

Table 7.2. Diffusion coefficients

Parameter Gas Liquid

Water 1.0E-6 1.0E-10

Brine 0.0 0.0

Radionuclide 1 1.0E-6 1.0E-10

Radionuclide 2 1.0E-6 1.0E-10

Air 1.0E-6 1.0E-10

Table 7.3. Parent Radionuclide Data

Parameter Value

Half Life 1.0E50

Molecular Weight 131.389

Inverse Henry's Constant 2.0996E-8

Table 7.4. Daughter Radionuclide Data

Parameter Value

Half Life 1.0E50

Molecular Weight 165.834

Inverse Henry's Constant 1.1816-8
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Material Properties

To specify the material properties, you use the Material Data dialog. This problem
uses three different materials: a material that represents the vadose zone (VADOS), a
material that represents the atmosphere (ATMOS), and a material that allows only dif-
fusion from the VOC source (TRAPP). We first define the vados material.

1. On the Properties menu, click Materials (or click on the toolbar).

2. In the Name box, type VADOS.

3. In the Density box, type 2600.0.

4. In the Porosity box, type 0.35.

5. In all three Permeability boxes (X, Y, and Z), type 1.0E-11.

6. In the Wet Heat Conductivity box, type 2.51.

7. In the Specific Heat box, type 920.0.

We also need to specify the relative permeability and capillary pressure functions for
this material. These options can be found in the Additional Material Data dialog. To
open this dialog, click the Relative Perm... button.

To specify the relative permeability function

1. Select the Relative Perm tab.

2. In the Relative Permeability list, select van Genuchten-Mualem Model.

3. In the Lambda box, type 0.457.

4. In the Slr box, type 0.15.

5. In the Sls box, type 1.0.

6. In the Sgr box, type 0.1.

To specify the capillary pressure function

1. Select the Capillary Press tab.

2. In the Capillary Pressure list, select van Genuchten Function.

3. In the Lambda box, type 0.457.

4. In the Slr box, type 0.0.

5. In the 1/P0 box, type 5.105E-4.
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6. In the Pmax box, type 1.0E7.

7. In the Sls box, type 1.0.

To specify the tortuosity

1. Select the Misc tab.

2. In the Tortuosity Factor box, type 0.25.

Click OK to exit the Advanced Material Data dialog. Click Apply to save the
changes for the VADOS material.

We will now create a new cap rock material, based on VADOS

1. In the Material Data dialog, click New.

2. In the Tough Name box, type TRAPP.

3. In the Description box, type VOC source.

4. In the Based On list, select VADOS.

5. Click OK to create the new material.

The TRAPP will represent a material with zero permeability that is a source of VOC
by diffusion only. Because it was based on the VADOS material, it has inherited all
the properties we previously defined for that material. We will only set the permeabilit-
ies to zero. To modify the TRAPP material

1. On the Materials list, make sure that TRAPP is selected.

2. In all three Permeability boxes (X, Y, and Z), type 0.0.

3. Click Apply to save the changes.

Finally, we will create one material to be used to represent the atmosphere. The atmo-
sphere is modeled with zero capillary pressure.

1. In the Material Data dialog, click New.

2. In the Tough Name box, type ATMOS.

3. In the Description box, type Atmosphere.

4. In the Based On list, select VADOS.

5. Click OK to create the new material.

To modify the ATMOS material
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1. On the Materials list, make sure that ATMOS is selected.

2. Click the Relative Perm... button to open the Additional Material Data dialog.

3. Click the Capillary Press tab.

4. In the Capillary Pressure list, select No Capillary Pressure.

5. Click the Misc tab.

6. In the Tortuosity Factor box, type 1.0.

7. Click OK to exit the Advanced Material Data dialog.

8. Click OK to save the changes and close the Material Data dialog.

Initial Conditions

The initial state of each cell in the model must be defined. The default initial condi-
tions represent an approximate starting state for the cells in the vadose zone above the
water table. Default initial conditions are applied to all cells that do not have initial
conditions specified individually. On the Properties menu, click Initial Conditions...
(or click on the toolbar).

To set the default initial conditions

1. Select the Two-Phase (Pg, Xb, Xrn1, Xrn2, Sg+10, T) state option.

2. In the Pressure box, type 1.013E5.

3. In the Temperature box, type 20.0.

4. In the Gas Saturation box, type 0.5.

5. In the Brine Mass Fraction box, type 0.0.

6. In the Parent Radionuclide Mass Fraction box, type 0.0.

7. In the Daughter Radionuclide Mass Fraction box, type 0.0.

8. Click OK.

For the bottom four cells that are below the water table, the initial conditions are single
phase liquid. To specify the initial conditions, we select the cells in the Grid Editor,.
To open the Grid Editor, on the Model menu, click Edit Grid (or click on the tool-
bar).

1. Open the Grid Editor. On the Model menu, click Edit Grid (or click on the
toolbar).
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2. In the Grid Editor, click on the View icon to select the YZ View.

3. Using the Selection tool, select the four bottom cells of the model.

4. Right-click on the first cell and click Initial Conditions..., Figure 7.3.

5. Click Specify Initial Conditions by Cell. The initial conditions for the individual
cells override the global values. Because these cells are below the water table,
they are single phase liquid. There is a small amount of dissolved air in the water.

6. Select the Single-Phase (P, Xb, Xrn1, Xrn2, X, T) state option.

7. In the Pressure box, type 1.5E5.

8. In the Temperature box, type 20.0.

9. In the Brine Mass Fraction box, type 0.0.

10. In the Parent Radionuclide Mass Fraction box, type 0.0.

11. In the Daughter Radionuclide Mass Fraction box, type 0.0.

12. In the Air Mass Fraction box, type 1.0E-12.

13. Click OK to close the Edit Multi-Cell Data dialog.

Figure 7.3. Selecting the bottom four cells.

The 5th cell from the bottom (Z=-10.5) will be the cell at the water table. During the
gravity/capillary equilibrium solution, all other cells values will be calculated relative
to this water table cell.
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1. In the Grid Editor, click on the View icon to select the YZ View.

2. Using the Selection tool, right-click on the fifth cell from the bottom, and click
Edit Properties....

3. In the Cell Name box, type Water Table.

4. In the Type box, select Fixed State. This means that this cell will not change
during the analysis, but will remain fixed at constant temperature, pressure, etc.

5. Click the Initial Conditions tab.

6. Click Specify Initial Conditions by Cell. The initial conditions for the individual
cells override the global values.

7. Select the Two-Phase (Pg, Xb, Xrn1, Xrn2, Sg+10, T) state option.

8. In the Pressure box, type 1.013E5.

9. In the Temperature box, type 20.0.

10. In the Gas Saturation box, type 0.2.

11. In the Brine Mass Fraction box, type 0.0.

12. In the Parent Radionuclide Mass Fraction box, type 0.0.

13. In the Daughter Radionuclide Mass Fraction box, type 0.0.

14. Click the Print Options tab.

15. Select the Print Cell Time Dependent Data check box. This will output extra
data for this cell every time step for later plotting.

16. Click OK to close the Edit Cell Data dialog.

Close the Grid Editor.

Add Extra Cells

Extra Cells are cells that are in addition to the geometric cells that define the solution
grid. In this model, they will be used to define boundary conditions at the top and bot-
tom. In the gravity/capillary equilibrium solution, these are Enabled and the state of
the cells will be calculated. In the transient analysis, these cells will be Fixed State and
they will define boundary conditions.

To add the Extra Cells

1. On the Model menu, click Add Extra Cell... .
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2. Click the Properties tab.

3. In the Cell Name box, type Top.

4. In the Volume box, type 1.0.

5. In the Material list, select ATMOS.

6. In the Type list, select Enabled.

7. Click the Initial Conditions tab.

8. Click Specify Initial Conditions by Cell.

9. Select the Single-Phase (P, Xb, Xrn1, Xrn2, X, T) state option.

10. In the Pressure box, type 1.013E5.

11. In the Temperature box, type 20.0.

12. In the Brine Mass Fraction box, type 0.0.

13. In the Parent Radionuclide Mass Fraction box, type 0.0.

14. In the Daughter Radionuclide Mass Fraction box, type 0.0.

15. In the Air Mass Fraction box, type 0.99.

16. Click the Print Options tab.

17. Select the Print Cell Time Dependent Data check box.

18. Click the Connected Cells tab. This table is used to input all the information that
will connect this cell to the model. Enter the values from Table 7.5, which corres-
pond to the input required by TOUGH2 for a CONNE connection record, Fig-
ure 7.4.

19. Click OK to close the Edit Cell Data dialog.

Table 7.5. Connection data for top extra cell

Parameter Value

'To' Cell 15

Orientation 3

Dist 'This' 1.0E-9

Dist 'To' 0.5

Area 1.0
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Parameter Value

Gravita... 1.0

Rad. H... 0.0

Figure 7.4. Top extra cell

Repeat these steps to add the bottom Extra Cell

1. On the Model menu, click Add Extra Cell... .

2. Click the Properties tab.

3. In the Cell Name box, type Bot.

4. In the Volume box, type 1.0.

5. In the Material list, select VADOS.

6. In the Type list, select Enabled.

7. Click the Initial Conditions tab.
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8. Click Specify Initial Conditions by Cell.

9. Select the Single-Phase (P, Xb, Xrn1, Xrn2, X, T) state option.

10. In the Pressure box, type 1.5E5.

11. In the Temperature box, type 20.0.

12. In the Brine Mass Fraction box, type 0.0.

13. In the Parent Radionuclide Mass Fraction box, type 0.0.

14. In the Daughter Radionuclide Mass Fraction box, type 0.0.

15. In the Air Mass Fraction box, type 1.0E-12.

16. Click the Print Options tab.

17. Select the Print Cell Time Dependent Data check box.

18. Click the Connected Cells tab. This table is used to input all the information that
will connect this cell to the model. Enter the values from Table 7.6, which corres-
pond to the input required by TOUGH2 for a CONNE connection record.

19. Click OK to close the Edit Cell Data dialog.

Table 7.6. Connection data for bottom extra cell

Parameter Value

'To' Cell 1

Orientation 3

Dist 'This' 1.0E-9

Dist 'To' 0.5

Area 1.0

Gravita... -1.0

Rad. H... 0.0

Select Cell for Time History Output

We can select cells to print output more frequently than the frequency for the entire
mesh.

1. Open the Grid Editor. On the Model menu, click Edit Grid (or click on the
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toolbar).

2. In the Grid Editor, click on the View icon to select the YZ View.

3. Right-click on the 11th cell up from the bottom and click Edit Properties.... The
Z Center should be at -4.5 m.

4. In the Name box, type VOC Link. This is the cell that will connect to the VOC
source in the transient analysis.

5. Click the Print Options tab.

6. Select the Print Cell Time Dependent Data check box.

7. Click OK to close the Edit Cell Data dialog.

8. Close the Grid Editor.

Solution Controls

We will set the end time of the analysis.

1. On the Analysis menu, click Solution Controls... (or click on the toolbar).

2. In the End Time box, type 3.155E12 sec (about 100,000 years). This large time
is needed to reach full equilibrium.

3. Click OK to exit the Solution Controls dialog..

Output Controls

By default, the simulation will print output every 100 time steps. We can increase the
frequency of the output in the Output Controls dialog.

1. On the Analysis menu, click Output Controls... (or click on the toolbar).

2. In the Print and Plot Every # Steps box, type 2.

3. Click OK to exit the Output Controls dialog.

Save and Run

The input is complete and you can run the simulation. If you haven't already, you may
want to save your model in a directory specifically intended for the simulation results.
For example

1. On the File menu, click Save (or click on the toolbar).

2. Create a new folder named Equilibrium and in the File Name box, type equilib-
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rium.sim.

3. Click Save.

To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

During the solution, a graph will display the time step size.

View 3D Results

To view the 3D results for a simulation, on the Results menu, click 3D Results (or
click on the toolbar). The data for the current simulation will be automatically
loaded and displayed.

To show liquid saturation contours

1. In the Time(s) list, select the last entry (3.155E12).

2. In the Scalar list, select SL.

3. Click to clear the Show Isosurfaces checkbox.

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Y.

2. In the Coord box, type 0.5.

3. Select the Scalar check box.

4. Click Close.

The resulting contour plot is shown in Figure 7.5. Below the water table, the soil is
completely saturated, above it has a partial saturation of about 0.154.

VOC Contamination
(TOUGH2 Problem 8)

91



Figure 7.5. Contours of liquid saturation (SL).

Close the 3D Results window.

View Cell History Plot

You can view time history plots with the Cell History dialog. On the Results menu,
click Cell History Plots.... (or click on the toolbar).

The Cell History dialog will be displayed. In this window, you can display time his-
tory data using a plotting parameter and a list of cells. For example, to view the tem-
perature in the Outflow cell

1. In the Variable list, select SL (saturation of liquid).

2. In the Cell Name (Id#) list, select VOC Link.

VOC Contamination
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Figure 7.6. Time history of liquid saturation showing convergence to steady state.

Close the Cell History window.

Transient Analysis

We will now use the equilibrium state results as initial conditions for a transient ana-
lysis. You will open the model file (equilibrium.sim) that we previously saved and then
save it to a new directory.

1. If the equilibrium analysis is not already open, on the File menu, click Open (or
click on the toolbar). In the File Name box, select the equilibrium.sim file and
click Open.

2. To save the transient model, on the File menu, click Save As....

3. Create a new folder named Transient and in the File Name box, type transi-
ent.sim.

4. Click Save.

Load Initial Conditions

To load the previously calculated equilibrium results and use them as initial conditions
for the transient analysis, we read the SAVE file that was output at the end of the equi-
librium analysis. This file has the results for all the cells in the model. To read these
initial conditions

1. On the File menu, click Load Initial Conditions... .

VOC Contamination
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2. Browse to the Equilibrium folder and select the SAVE file.

3. Click Open. This reads the saved data from the previous run and stores it as an
initial condition for each cell in the current analysis.

To view the initial conditions, open the Grid Editor

1. On the Model menu, click Edit Grid (or click on the toolbar).

2. In the Grid Editor, click on the View icon to select the YZ View.

3. In the Property list, select Pressure.

4. The display will show the pressures from the equilibrium analysis, Figure 7.7.

Figure 7.7. Default initial conditions.

Add VOC Source Cell

An Extra Cell is used to define the VOC source

1. On the Model menu, click Add Extra Cell... .

2. Click the Properties tab.

3. In the Cell Name box, type Source.

4. In the Volume box, type 1.0.

5. In the Material list, select TRAPP.

VOC Contamination
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6. In the Type list, select Fixed State.

7. Click the Initial Conditions tab.

8. Click Specify Initial Conditions by Cell.

9. Select the Two-Phase (Pg, Xb, Xrn1, Xrn2, Sg, T) state option.

10. In the Pressure box, type 1.0123E5.

11. In the Temperature box, type 20.0.

12. In the Gas Saturation box, type 0.84353.

13. In the Brine Mass Fraction box, type 0.0.

14. In the Radionuclide 1 box, type 1.0998E-3.

15. In the Radionuclide 1 box, type 2.0063E-4.

16. Click the Print Options tab.

17. Select the Print Cell Time Dependent Data check box.

18. Click the Connected Cells tab. This table is used to input all the information that
will connect this cell to the model. Enter the values from Table 7.7, which corres-
pond to the input required by TOUGH2 for a CONNE connection record.

19. Click OK to close the Edit Cell Data dialog.

Table 7.7. Connection data for source cell

Parameter Value

'To' Cell 11

Orientation 1

Dist 'This' 1.0E-9

Dist 'To' 0.5

Area 0.1

Gravita... 0.0

Rad. H... 0.0

Change Fixed Cells
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In the equilibrium analysis, we reached a steady state condition for gravity and capil-
lary equilibrium. We will now use those values to define fixed top and bottom condi-
tions for the model.

1. Open the Grid Editor. On the Model menu, click Edit Grid (or click on the
toolbar).

2. In the Grid Editor, click on the View icon to select the YZ View.

3. Using the Selection tool, right-click on the fifth cell from the bottom, and click
Edit Properties....

4. In the Type box, select Enabled. This means that this cell is now part of the
analysis.

5. Click OK to close the Edit Cell Data dialog.

6. Close the Grid Editor window.

We now change the extra cells to a fixed state to define the boundary conditions for the
transient analysis.

1. In the Tree View (on the left of the display), expand the Extra Cells icon and
double-click on the Top cell.

2. On the Properties tab, in the Type box, select Fixed State.

3. Click OK to close the Edit Cell Data dialog.

Repeat for the bottom (Bot) cell.

Solution Controls

We will now define the solution options.

1. On the Analysis menu, click Solution Controls... (or click on the toolbar).

2. In the End Time box, type 3.1557E9 sec (about 100 years).

3. Click OK to exit the Solution Controls dialog..

Output Controls

By default, the simulation will print output every 100 time steps. We can increase the
frequency of the output in the Output Controls dialog.

1. On the Analysis menu, click Output Controls... (or click on the toolbar).

2. In the Print and Plot Every # Steps box, type 2.

VOC Contamination
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3. Click Edit.

4. In the Additional Print Times table, type 3.15576e7 (about 1 year). This will
force a solution printout at this time.

5. Click OK to exit the Additional Print Times dialog.

6. Click OK to exit the Output Controls dialog.

Run Transient Analysis

To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar). The model file will automatically be saved.

During the solution, a graph will display the time step size.

View Transient 3D Results

To view the 3D results for the transient simulation, on the Results menu, click 3D
Results (or click on the toolbar). The data for the current simulation will be auto-
matically loaded and displayed.

To show the mass fraction of radionuclide in the gas

1. In the Time(s) list, select the 3.156E7 time.

2. In the Scalar list, select XRN!(GAS).

3. Click to clear the Show Isosurfaces checkbox.

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Y.

2. In the Coord box, type 0.5.

3. Select the Scalar check box.

4. Click Close.

The resulting contour plot is shown in Figure 7.8.
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Figure 7.8. Contours of mass fraction of radionuclide 1 (TCE) in gas at one year.

Close the 3D Results window.

View Cell History Plots

You can view time history plots with the Cell History dialog. On the Results menu,
click Cell History Plots.... (or click on the toolbar).

The Cell History dialog will be displayed. In this window, you can display time his-
tory data using a plotting parameter and a list of cells. For example, to view the tem-
perature in the Outflow cell

1. In the Variable list, select XRn1(gas).

2. In the Cell Name (Id#) list, select Water Table.

VOC Contamination
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Figure 7.9. Time history of mass fraction of radionuclide 1 (TCE) in gas in Water Table cell.

Close the Cell History window.
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Chapter 8. CO2 Injection (ECO2N)

Description

This example is Problem 2 "Radial Flow from a CO2 Injection Well" in the ECO2N
module description, [Pruess, 2005]. This is a basic problem of CO2 injection into a sa-
line aquifer, examining two-phase flow with CO2 displacing (saline) water under con-
ditions that may be encountered in brine aquifers at a depth of the order of 1.2 km. A
CO2 injection well fully penetrates a homogeneous, isotropic, infinite-acting aquifer of
100 m thickness (Fig. 13), at conditions of 120 bar pressure, 45 C temperature, and a
salinity of 15% by weight. CO2 is injected uniformly at a constant rate of 100 kg/s.
This problem had been included as test problem #3 in a recent code intercomparison
project ([Pruess and Garcia, 2002] and [Pruess et al., 2002].

Figure 8.1. Schematic of problem

Specify the Equation of State (EOS)

To ensure that PetraSim uses ECO2N, edit your PetraSim preferences using the Pref-
erences dialog.

1. On the File menu, click Preferences... .

2. In the Simulator Mode list, select TOUGH.

3. In the Default EOS list, select ECO2N.
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4. Click OK.

Your preferences have now been updated, but you will need to create a new model or
restart PetraSim before they become active. If you already have a model open, it will
not be affected by the preference change. On the File menu, click New.

Create the Model Boundary

To create the boundary, use the Define Model Boundary dialog. The boundary para-
meters for this model are shown in Table 8.1.

Table 8.1. Model boundary dimensions

Axis Min (m) Max (m)

x 0.3 100000.0

y 0.0 1.0

z 0.0 100.0

To create the model boundary

1. On the Model menu, click Define Boundary... (or click on the toolbar).

2. Enter the values from Table 8.1.

3. Click OK to create the model boundary.

Because this model has a very large radius, we will need to scale the dimension in the
Z direction in order to manipulate the model. To do this

1. On the View menu, click Scale Axis....

2. In the Z Factor box, type 500.

3. Click OK to close the Scale Axis dialog.

You can rotate, pan, and zoom the model using the mouse and Shift and Alt keys.

Create the Grid

To create the solution grid

1. On the Model menu, click Create Grid... (or click on the toolbar).

2. In the Division Method box, select Regular.

CO2 Injection (ECO2N)
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3. Click Cells Above Top and Below Bottom are Inactive.

4. Click RZ Grid. This creates a 2D cylindrical grid. It will be displayed as a plane,
but when the solution data is written, the volume and connections for the cells
will be calculated in cylindrical coordinates.

5. In the X Cells box, type 500.

6. In the X Factor box, type 1.02. This will exponentially increase the cell size in
the X (radial) direction. See the PetraSim User Manual for instructions on how to
calculate this factor.

7. In the Z Cells box, type 1.

8. In the Z Factor box, type 1.0.

9. Click OK to create the grid.

The resulting mesh is displayed in Figure 8.2. Click the Front View in the toolbar to
display the model as shown below.

Figure 8.2. The resulting mesh

Global Properties

Global properties are those properties that apply to the entire model. We will make

CO2 Injection (ECO2N)

102



changes to some of the EOS options, including activating molecular diffusion. To edit
global properties, you use the Global Properties dialog.

On the Properties menu, click Global Properties... (or click on the toolbar).

1. Click the Analysis tab.

2. In the Name box, type CO2 Injection.

3. Click the EOS tab.

4. Select Isothermal.

5. Select Tubes in Series.

6. In the phi box, type 0.8.

7. In the G box, type 0.8.

8. Click OK to close the Global Properties dialog.

Material Properties

To specify the material properties, you use the Material Data dialog. This example re-
quires one material.

1. On the Properties menu, click Materials (or click on the toolbar).

2. In the Name box, type SAND.

3. In the Density box, type 2600.0.

4. In the Porosity box, type 0.12.

5. In all three Permeability boxes (X, Y, and Z), type 1.0E-13.

6. In the Wet Heat Conductivity box, type 2.51.

7. In the Specific Heat box, type 920.0.

8. Click Apply to save the changes.

In addition to the physical rock parameters, we also need to specify the relative per-
meability and capillary pressure functions for this material. These options can be found
in the Additional Material Data dialog. To open this dialog, click the Relative
Perm... button.

To specify the relative permeability function
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1. Select the Relative Perm tab.

2. In the Relative Permeability list, select van Genuchten-Mualem Model.

3. In the Lambda box, type 0.457.

4. In the Slr box, type 0.3.

5. In the Sls box, type 1.0.

6. In the Sgr box, type 0.05.

To specify the capillary pressure function

1. Select the Capillary Press tab.

2. In the Capillary Pressure list, select van Genuchten Function.

3. In the Lambda box, type 0.457.

4. In the Slr box, type 0.0.

5. In the 1/P0 box, type 5.1E-5.

6. In the Pmax box, type 1.0E7.

7. In the Sls box, type 0.999.

To specify the pore compressibility

1. Select the Misc tab.

2. In the Pore Compressibility box, type 4.5E-10.

Click OK to exit the Advanced Material Data dialog.

Click OK again to save your settings and exit the Material Data dialog.

Initial Conditions

The initial state of each cell in the model must be defined. To specify global initial
conditions that will be used as the default for all cells in the model

To set the initial conditions

1. On the Properties menu, click Initial Conditions... (or click on the toolbar).

2. Select the Single-Phase (P, Xsm, Xncg, T) state option.

3. In the Pressure box, type 120.0E5.
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4. In the Temperature box, type 45.0.

5. In the Salt Mass Fraction box, type 0.15.

6. In the CO2 Mass Fraction box, type 0.0.

7. Click OK to close the Default Initial Conditions dialog.

Define CO2 Injection

This model has CO2 injected into the borehole. This is defined in the Grid Editor.

1. On the Model menu, click Edit Grid (or click on the toolbar).

2. In the Grid Editor, click on the View icon to select the XZ View.

3. On the View menu, click Scale Axis....

4. In the Z Factor box, type 500.

5. Using the Zoom Box tool, zoom in to the top left of the model until you can see
the first cell.

6. Using the Selection tool, right-click on the first cell and click Edit Properties...,
Figure 8.3.

7. In the Cell Name box, type Injection.

8. Click the Sources/Sinks tab.

9. In the Injection section, select the CO2 check box.

10. In the Rate box, type 100.

11. Click the Print Options tab.

12. Select the Print Cell Time Dependent Data check box.

13. Click OK to close the Edit Cell Data dialog.
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Figure 8.3. The cell to select

Select Additional Cell for Time History Output

We can select cells to print output more frequently than the frequency for the entire
mesh.

1. On the Model menu, click Edit Grid (or click on the toolbar).

2. In the Grid Editor, click on the View icon to select the XZ View.

3. In the Find box, type 200. This will select cell number 200, which is located at a
radius of 255 m.

4. On the Edit menu, click Properties. This will open the properties of this cell for
editing.

5. In the Name box, type R=255.

6. Click the Print Options tab.

7. Select the Print Cell Time Dependent Data check box.

8. Click OK to close the Edit Cell Data dialog.

9. Close the grid editor.
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Solution Controls

We will now define the solution control options.

1. On the Analysis menu, click Solution Controls... (or click on the toolbar).

2. In the End Time box, type 8.64E8.

3. In the Time Step list, ensure that Single Value is selected.

4. In the Time Step box, type 1.0. This is the initial time step.

5. In the Max Num Time Steps box, type 2000.

6. Select Enable Automatic Time Step Adjustment.

7. Click the Solver tab.

8. Select Stabilized Bi-Conjugate Gradient.

9. Click OK to exit the Solution Controls dialog..

Output Controls

By default, the simulation will print output every 100 time steps. We can increase the
frequency of the output in the Output Controls dialog.

1. On the Analysis menu, click Output Controls... (or click on the toolbar).

2. In the Print and Plot Every # Steps box, type 50.

3. Click OK to exit the Output Controls dialog.

Save and Run

The input is complete and you can run the simulation. If you haven't already, you may
want to save your model in a new directory. For example

1. On the File menu, click Save (or click on the toolbar).

2. Create a new folder named ECO2N and in the File Name box, type eco2n.sim.

3. Click Save.

To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

During the solution, a graph will display the time step size.

View 3D Results
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To view the 3D results for a simulation

1. On the Results menu, click 3D Results (or click on the toolbar). The data for
the current simulation will be automatically loaded and displayed.

Since the model has a large radius relative to its height, we scale the Z coordinates.

1. On the View menu, click Scale Axes....

2. In the Z Factor box, type 500.

3. On the View menu, click Front View (or click on the toolbar).

To show pressure contours for the last time step

1. In the Time(s) list, select the last entry (8.64E8).

2. In the Scalar list, select P (Pa).

3. Click to clear the Show Isosurfaces checkbox.

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Y.

2. In the Coord box, type 0.5.

3. Select the Scalar check box.

4. Click Close.

After zooming in to the left side of the model, the resulting contour plot is shown in
Figure 8.4.
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Figure 8.4. Pressure contours

Close the 3D Results window.

Time History Plots

You can view time history plots with the Cell History dialog. On the Results menu,
click Cell History Plots.... (or click on the toolbar).

The Cell History dialog will be displayed. In this window, you can display time his-
tory data using a plotting parameter and a list of cells. For example, to view the tem-
perature in the Heat Source cell

1. In the Variable list, select Sg (gas saturation).

2. In the Cell Name (Id#) list, select R=255.
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Figure 8.5. Cell history plot of gas saturation for the cell at 255 m

Close the Cell History window.

Line Plots

PetraSim also supports line plots, where you define a line in 3D space and the data is
interpolated along the line. To make a line plot

1. On the Results menu, click 3D Results (or click on the toolbar).

2. On the File menu, click Line Plot....

3. In the Point 1 coordinate boxes (X, Y, and Z) type 0.3, 0.5, and 50.0, re-
spectively.

4. In the Point 2 coordinate boxes (X, Y, and Z) type 1000.0, 0.5, and 50.0, re-
spectively.

5. Click OK to close the Line Plot dialog.

6. This will open a Line Plot window.

7. In the Variable list, select P (Pa).

8. In the Time list, select 8.64E8 (the last time).
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The plot is shown in Figure 8.6. You can export this data to a comma separated value
file for import into a spreadsheet.

Figure 8.6. Line plot of pressure

Close the Line Plot window.

Figure 8.7 displays the results in a format that can be compared to the plot in the
ECO2N User's Manual. These were made in Excel by importing the saved line plot
data. The present results are the same as given in the manual.
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Figure 8.7. Results at time 8.64E7 s (for comparison with ECO2N manual)
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Chapter 9. T2VOC Example Problem 1

Description

This example demonstrates one dimensional gas diffusion of an organic chemical with
phase partitioning - as described in the T2VOC User's Guide (Ralta, Pruess, Finsterle,
and Battistelli, LBL-36400, 1995).

A horizontal column has an initial temperature of 10 C and an initial pressure of
101325 Pa. The left cell has a fixed thermodynamic state and acts as a source of
chlorobenzene. The geometry of the problem is shown in Figure 9.1.

Figure 9.1. Example Problem Overview

We will use a mesh with 150 cells in the horizontal direction.

Specify the T2VOC Simulator

To ensure that PetraSim uses T2VOC as the simulator for this problem, you may need
to edit your PetraSim preferences. To edit preferences, you can use the PetraSim Pref-
erences dialog.

1. On the File menu, click Preferences....

2. In the Simulator Mode list, select TOUGH.

3. In the Default EOS list, select T2VOC.

4. Click OK.

Your preferences have now been updated, but you will need to create a new model or
restart PetraSim before they become active. If you already have a model open, it will
be unaffected by the preferences change.

On the File menu, click New

Create the Model Boundary
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To create the boundary for this model, you can use the Define Model Boundary dia-
log. This example will use the x-axis as the horizontal direction. The boundary para-
meters for this model are shown in Table 9.1.

Table 9.1. Model boundary dimensions

Axis Min (m) Max (m)

x 0.0 15.0

y 0.0 1.0

z 0.0 1.0

To create the model boundary:

1. On the Model menu, click Define Boundary... (or click on the toolbar).

2. Enter the values from Table 9.1.

3. Click OK to create the model boundary.

You can rotate, pan, and zoom the model using the mouse and Shift and Alt keys. The
resulting boundary is shown in Figure 9.2. PetraSim will automatically add labels for
the min point and max point of the boundary.

T2VOC Example Problem 1
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Figure 9.2. The Model Boundary

Create the Grid

To create the grid:

1. On the Model menu, click Create Grid... (or click on the toolbar).

2. In the Division Method box, select Regular.

3. In the X Cells box, type 150.

4. In the Y Cells box, type 1.

5. In the Z Cells box, type 1.

6. Click OK to create the grid.

Global Properties

Global properties are those properties that apply to the entire model. In this example
we will set the simulation name and configure the simulation VOC. To edit global
properties, you can use the Global Properties dialog.

On the Properties menu, click Global Properties... (or click on the toolbar).

Simulation Name

1. In the Global Properties dialog, select the Analysis tab.

2. In the Name box, type T2VOC Problem 1.

EOS Data

The EOS (Equation of State) tab displays options for the T2VOC simulator. In this ex-
ample, we will perform an isothermal (no heat flow) analysis. We will also specify a
variant of chlorobenzene as the simulation VOC and specify the Air-Vapor diffusion
constant.

In the Global Properties dialog, select the EOS tab

By default, the simulator will run in isothermal mode. Nothing needs to be changed.

To specify the VOC, you will need to create a variant of chlorobenzene using the Edit
VOC Data dialog.

1. Click Edit VOC Data....

T2VOC Example Problem 1
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2. Click New.

3. In the Name box, type Chlorobenzene Ex 1

4. In the Based On list, select Chlorobenzene (STD).

5. Click OK. This creates a new VOC.

6. Update the values for CHEMP.4, CHEMP.6, and CHEMP.7 according to the
values shown in Table 9.2, Table 9.3, and Table 9.4.

7. Click OK and ensure that the selected Simulation VOC is Chlorobenzene Ex 1

8. This simulation will use gas diffusion. You can enable gas diffusion by setting the
Air-Vapor Diffusion to a non-zero value. In the Air-Vapor Diffusion box, type
2.13e-5.

9. Click OK to close the Global Properties dialog.

Table 9.2. Chlorobenzene Ex 1 (CHEMP.4)

Field Value

Ref NAPL 1106.0

Ref Temp for NAPL 293

Ref Binary Diffusivity in Air 8.0e-6

Ref Temp for Gas Diffusivity 283.15

Chem Diffusivity Exponent 1.0

Table 9.3. Chlorobenzene Ex 1 (CHEMP.6)

Field Value

SOLA 7.996e-5

SOLB 0.0

SOLC 0.0

SOLD 0.0

Table 9.4. Chlorobenzene Ex 1 (CHEMP.7)

T2VOC Example Problem 1

116



Field Value

Chem Organic Carbon Partition Coef 0.15

Default Fraction of Organic Carbon 0.005

VOC Biodegradation Decay Constant 0.0

Figure 9.3. T2VOC Simulation Parameters

Material Properties

To specify the material properties, you can use the Material Data dialog.

1. On the Properties menu, click Materials (or click on the toolbar).

2. In the Name box, type DIRT1

3. In the Density box, type 2650.0

4. In the Porosity box, type 0.4

5. In all three Permeability boxes, type 1e-14

6. In the Wet Heat Conductivity box, type 3.1

7. In the Specific Heat box, type 1000.0

8. Click Apply to save the changes

T2VOC Example Problem 1

117



We still need to specify the relative permeability function and fraction of organic car-
bon for this material. These options can be found in the Advanced Material Data dia-
log. To open this dialog, click the Relative Perm... button.

To specify the relative permeability function:

1. Select the Relative Perm tab

2. In the Relative Permeability list, select Stone's 3-Phase

3. In the Swr box, type 0.4

4. In the Snr boxes, type 0.1

5. In the Sgr box, type 1.0e-3

6. In the n box, type 1.0

The default capillary pressure (none) is correct for this example.

To specify the fraction of organic carbon:

1. Select the Misc tab

2. In the Fraction of Organic Carbon box, type 0.005

Click OK to exit the Additional Material Data dialog.

Click OK again to save your settings and exit the Material Data dialog.

Initial Conditions

You can control the initial state of the primary variables using initial conditions.
Primary variable selection will depend on several factors including EOS selection, sim-
ulator mode, and the initial state of the simulation. You can edit initial conditions glob-
ally and on a cell-by-cell basis.

To edit global initial conditions: on the Properties menu, click Initial Conditions...

For this example, we will initialize all cells to a two-phase water and air state. There is
no initial chlorobenzene saturation. To set the initial conditions:

1. Select the Two-Phase Water/Air state option

2. In the Pressure box, type 101325.0

3. In the Temperature box, type 10.0

4. In the Water Saturation box, type 0.25
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5. In the VOC Mole Fraction in Air box, type 0.0

6. Click OK

Boundary Conditions

We will inject chlorobenzene into the model using a cell-specific initial condition.
Then we will force the state of that cell to remain constant. To edit individual cells,
you can use the Grid Editor.

To open the Grid Editor: on the Model menu, click Edit Grid (or click on the
toolbar).

Every cell in the model has a unique ID number. You can find and select cells based on
their ID number using the Find field in the upper-right corner of the Grid Editor. In
this example, cell 1 will be the chlorobenzene source. To find and select cell 1:

1. In the Find box, type 1

2. Press ENTER. The cell should be selected and shown in the center of the grid edit-
or.

Figure 9.4. Finding a Cell in the Grid Editor

You can now edit the properties of cell 1. Ensure cell 1 is selected. On the Edit menu,
click Properties...

To force the state of this cell to remain constant throughout the simulation, you can ad-
just its type. Select the Properties tab. Then, in the Type list, select Fixed State.

Now you can give the cell a custom initial condition that will remain constant
throughout the simulation. Select the Initial Conditions tab. To enter the custom ini-
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tial conditions:

1. Select Specify Initial Conditions by Cell

2. Select the Three-Phase Water/Air/NAPL state

3. In the Water Saturation box, type 0.2

Notice that we did not explicitly specify a NAPL saturation. With the gas saturation at
0.75 and the water saturation at 0.2 the NAPL saturation will be 0.05. T2VOC will
perform this calculation during the simulation.

Click OK to close the Edit Cell Data dialog

On the File menu, click Close to exit the grid editor.

Solution Controls

We will now adjust the time step T2VOC will use while executing the simulation. Op-
tions relating the time step and other simulation options can be found in the Solution
Controls dialog.

To open the Solution Controls dialog: on the Analysis menu, click Solution Con-
trols... (or click on the toolbar).

For this example, we will adjust the end time, increase the maximum number of time
steps, and limit the size of the maximum time step.

1. In the End Time box, type 3.1558e7

2. In the Max Num Time Steps box, type 350

3. In the Max Time Step list, select User Defined

4. In the Max Time Step box, type 4.32e5

Click OK to exit the Solution Controls dialog.

Output Controls

By default, T2VOC will print output every 100 time steps. We can increase the resolu-
tion of the output with the Output Controls dialog.

1. On the Analysis menu, click Output Controls... (or click on the toolbar).

2. In the Print and Plot Every # Steps box, type 5

3. Click OK to exit the Output Controls dialog.

Save and Run
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The input is complete and you can now run the simulation. Bear in mind that T2VOC
generates many output files and they will overwrite the output from any previous simu-
lations in a directory. If you haven't already, you may want to save your model in a dir-
ectory specifically intended for the simulation results. For example:

1. On the File menu, click Save (or click on the toolbar).

2. Create a new folder named T2VOC Problem 1 and in the File Name box, type
t2voc_prob1.sim.

3. Click Save.

To run the simulation, on the Analysis menu, click Run TOUGH2 (or click on the
toolbar).

During the solution, a graph will display the time step size. In this case, the time steps
increase until they remain constant at the specified maximum.

Figure 9.5. Running T2VOC

View 3D Results

To view the 3D results for a simulation

1. On the Results menu, click 3D Results (or click on the toolbar). The data for
the current simulation will be automatically loaded and displayed.

To view the VOC concentration for the last time step

1. In the Time(s) list, select the last entry (3.156E7).
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2. In the Scalar list, select CVOCGAS.

3. Click to clear the Show Isosurfaces checkbox.

To add a slice plane on which contours will be displayed, click Slice Planes.... For this
example we will show one slice plane. To configure the slice plane

1. In the Axis list, select Z.

2. In the Coord box, type 0.5.

3. Ensure that the Scalar check box is checked.

4. Click Close.

Your results should now look similar to the screenshot in Figure 9.6. You can now see
the gas-phase VOC concentration emanating from the left side of the model.

Figure 9.6. T2VOC 3D Results

Close the 3D Results window.
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