PetraSim 5:
Getting Started
# Table of Contents

Table of Contents ........................................................................................................................................ iii
Figures ........................................................................................................................................................ iv

1.0 Licensing and Activation ......................................................................................................................... 1
2.0 Creating a Steady-State Model .................................................................................................................. 2
   Create a New Model ................................................................................................................................... 2
   Edit Layer Data .......................................................................................................................................... 2
   Create a Mesh ............................................................................................................................................ 2
   Edit the Top Layer of Cells ....................................................................................................................... 2
   Save and Run ........................................................................................................................................... 3
3.0 3D Results .................................................................................................................................................. 3
   Load Results as Initial Conditions ............................................................................................................ 4
   Using this Approach ................................................................................................................................. 5

3.0 Troubleshooting ..................................................................................................................................... 6
   Simulation Error Log ................................................................................................................................. 6
   Simulation Output Files ............................................................................................................................. 7
   PetraSim Crash Logs ............................................................................................................................... 7
Figures
Figure 1: The PetraSim Licensing Dialog ................................................................. 1
Figure 2: The New Model dialog .................................................................................. 2
Figure 3: PetraSim model, showing cells and top layer selection .................................... 3
Figure 4: The Running dialog, showing a completed simulation ...................................... 3
Figure 5: 3D Results showing a pressure slice .............................................................. 4
Figure 6: The main view, using cell color to display initial pressure ............................... 4
Figure 7: Error message indicating that a simulation halted prematurely ....................... 6
Figure 8: Table of log files for different simulators ...................................................... 7
Figure 9: A fatal error message in PetraSim .................................................................... 7
1.0 Licensing and Activation

The first time PetraSim is opened it will display the Licensing and Activation dialog, shown below. To enter your license information:

1. Select **Online Activation**.
2. In the **Key** box, enter your activation key (provided via email or online).
3. Click **Activate** to acquire your license. PetraSim will automatically download and install your license file. Licensing information will appear at the bottom of the dialog.
4. Press **OK** to begin using PetraSim.

![Figure 1: The PetraSim Licensing Dialog](image)

If you experience any problems with your activation key, you can retrieve an activation file manually at [www.thunderheadeng.com/license](http://www.thunderheadeng.com/license). The activation file can then be used by selecting **Local License** and clicking **Install License File**. Alternately, please contact support@thunderheadeng.com to request a license file by email.
2.0 Creating a Steady-State Model

The following tutorial will show you how to run a simple model to steady state. This process is often used as a first step to initialize state variables with reasonable values. This helps prevent convergence errors in subsequent simulations.

Create a New Model

In this step we will create a new TOUGH2 (EOS1) model, and initialize the model to be a 100x100x100 meter cube.

1. On the File menu, click New...
2. Under Simulator Mode, select TOUGH2
3. Under Equation of State (EOS), select EOS1
4. Under Model Bounds, in each Max box, type 100
5. Click OK to create the new model

Edit Layer Data

The number of Z-divisions in the model is controlled by the layers. A model can have many layers (though by default, there is only one layer), and each layer contains a number of Z divisions. For this model, we want ten cells in the Z direction.

2. In the Cells box, type 10
3. Click OK to save changes to the default layer

Create a Mesh

Right now, the model has not yet been divided up into cells. With the layer data correctly specified, we can use the Create Mesh dialog to generate a 10x10x10 mesh.

1. On the Model menu, click Create Mesh
2. In the X Cells box, type 10
3. In the Y Cells box, type 10
4. Click OK to create the mesh

The simulation mesh is based on layer data and the model boundary. Both of these can be changed at any time during the simulation, but doing so almost always makes it necessary to regenerate the mesh. Regenerating the mesh will destroy any data that has been specified at the cell level.

Edit the Top Layer of Cells

In this example, we will force the top layer of the mesh to remain at atmospheric pressure. The remaining portion of the mesh will adjust itself accordingly until it reaches a steady state.

To edit the top layer of the mesh:
1. Right-click any cell in the top (max Z) layer of the mesh
2. In the popup menu, click **Select Mesh Layer**
3. On the **Edit** menu, click **Properties**

These steps will open the **Edit Cell Data** dialog. Notice that because multiple cells are selected certain values (e.g. Cell ID) are displayed as a range.

To edit cell data:
1. In the **Type** list, select **Fixed State**
2. Click **OK** to save changes

The default values for pressure and temperature are a sufficient approximation for surface temperature and pressure.

### Save and Run

It is usually a good idea to create a new folder for each simulation. TOUGH2 uses a fixed set of names for the output files and running multiple simulations in one folder will usually destroy the previous output.

1. Create a new folder on your computer
2. On the **File** menu, click **Save** to save the model

To run the simulation:

1. On the **Analysis** menu, click **Run TOUGH2**
2. When the **Simulation Complete** dialog appears, click **OK**
3. Click **Close** to exit the **Running** dialog

### 3D Results

To view the results of the steady-state simulation:

1. On the **Results** menu, click **3D Results**
2. In the **3D Results** dialog, on the toolbar, click **Front View**

By default, a number of isosurfaces will be displayed, but in this case, isosurfaces are not very helpful. To turn off isosurfaces and use a slice plane instead:

1. At the left, click to de-select **Show Isosurfaces (Scalar)**
2. Click **Slice Planes...**
The Slice Planes dialog will appear. You use up to four slice planes at a time. The following instructions refer to the top row (first slice plane).

To create a slice plane at \( Y = 50 \):

1. Under Axis, select \( Y \)
2. In the Coord box, type 50
3. Click Close

You should now see a gradient with lower pressure at the top (1.1e5) and higher pressure at the bottom (9.82e5).

To close the 3D results dialog:

1. On the File menu, click Close

![Figure 5: 3D Results showing a pressure slice](image1)

---

**Load Results as Initial Conditions**

We performed this simulation to establish a reasonable set of initial conditions for a subsequent model. The next step will be to actually load those initial conditions. PetraSim uses the values stored in the SAVE file output by TOUGH2 to load initial conditions.

To load initial conditions:

1. On the File menu, click Load Initial Conditions...
2. Locate the SAVE file from the simulation output (it will be in the folder where you saved the model)
3. Select the SAVE file and click Open

The values from the SAVE file have now been copied into each cell in the model. You can view the new values in the main 3D view using the Cell Color toolbar option.

1. On the toolbar, in the Cell Color list, select Pressure
2. Click Front View, or left-click and drag to rotate the model for a better view

![Figure 6: The main view, using cell color to display initial pressure](image2)

The last step is to remove the fixed-state boundary condition on the top layer of cells. To reset the Type of the top layer of cells back to auto:

1. Right-click any cell in the top layer, in the popup menu, click Select Mesh Layer(s)
2. On the Edit menu, click Properties
3. In the Type list, select Auto

The Auto setting means that these cells will be enabled if the containing layer and region are enabled.

**Using this Approach**

Using the simulator to generate realistic initial conditions is a good way to start any model. In addition to making complex models less error-prone when running, running the simulation once ensures that any problems encountered later will not be due to problematic geometry or an otherwise faulty basic setup.
3.0 Troubleshooting

PetraSim is a user interface for separate computer programs that perform the actual simulation. Because of this separation, it can sometimes be challenging to understand what went wrong during a simulation. The following sections offer suggestions for how to work with common problems.

In addition to the steps below, you can always email alison@rockware.com or support@thunderheadeng.com for help. For questions about the user interface part of PetraSim, these contacts will be excellent sources of assistance. While they have considerable modeling experience, problems with a specific simulator or modeling approach may be much more difficult to answer, but in these cases the support staff can usually arrange a discussion with the model developers at LBNL or elsewhere.

Simulation Error Log

As a simulation runs, it generates output. This output is all gathered in the standard files for that simulator, and PetraSim also captures selected elements and displays a log during the simulation. Usually this log displays standard time step data, but sometimes it contains warning and error messages. Any output PetraSim identifies as an error or a warning is displayed in the simulation log window, in red text.

Figure 7 shows an error message that was created by not fixing the state variables in a model similar to the one created in the previous chapter – creating a vacuum. The popup message provides a link to the primary output file for the simulation (output that the simulator wrote to the standard output channel). Clicking the link in the dialog will open the output file in Notepad. This output file often contains a tremendous amount of data (the same file can be used to generate 3D results) and is usually more information than is needed to resolve the problem.

The Log tab shows several warning messages similar to "EOS CANNOT FIND PARAMETERS AT..." followed by a notice that the simulator is reducing the time step.

This is a common error messages and indicates that the primary variables are outside acceptable ranges in the listed cell and that the simulator will use a smaller time step to attempt to resolve the problem. If a simulation fails to converge, error messages such as these sometimes provide enough information to fix the problem without reading the raw output files.
Simulation Output Files
The simulation log files can be very useful in diagnosing simulation problems. These files vary from simulator to simulator. Use the table below to identify which files go with a particular simulator.

<table>
<thead>
<tr>
<th>Simulator</th>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TOUGH2, TMVOC</td>
<td>savename.out</td>
<td>Log of all text printed to the standard output</td>
</tr>
<tr>
<td>TOUGHREACT</td>
<td>flow.out</td>
<td>Log of all text printed to the standard output</td>
</tr>
<tr>
<td></td>
<td>runlog.out</td>
<td>Simulator event log</td>
</tr>
<tr>
<td></td>
<td>iter.out</td>
<td>Information about solver iterations</td>
</tr>
</tbody>
</table>

Figure 8: Table of log files for different simulators

Each of these files is output in plain text and can be opened with a text editor such as Notepad or WordPad.

PetraSim Crash Logs
Ideally, PetraSim would never crash. However, sometimes a crash accompanied by an error log is preferable to a frozen application. If the software detects that it has entered an invalid state and can no longer continue, PetraSim should display an error dialog similar to the one shown in Figure 9.

This error message indicates the existence of two new files: a log file and a backup of the current model.

The log file contains a "stack trace" that the developers can use to determine where the error occurred in PetraSim's source code. This file contains a list of function invocations arranged in a stack, with the last function call at the top. Adventurous users may try to diagnose the problem using the function names as a guide, but without benefit of the source code and an understanding of how the software is structured, this is a very difficult task. By sending this log file to one of the support emails listed in the introduction to this chapter, users can get an explanation for the crash and a workaround. In addition, the developers can use this information to improve PetraSim.

The second file listed is a PetraSim save file containing the current model immediately after the crash. This file can sometimes be used to recover your data, but because the error that crashed PetraSim has already occurred, this file is not always valid and is no substitute for frequently saving your work.