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Burner Fire 
In this tutorial you will create a 500 kW burner fire and measure the temperature in the center of the 

plume at a height of 1.5 m. This example defines a fire by specifying a Heat Release Rate (HRR). This is 

both the simplest and most commonly used approach for fire safety engineers to represent fire. 

For this example, it is sufficient to understand that modeling a fire using the heat release rate requires 

the user to specify two pieces of input data: 

 A reaction that defines the products and energy release during combustion and, 

 A heat release rate that defines size of the fire. When this is specified, FDS actually releases fuel 

at a mass flow rate based on the reaction energy for complete combustion. This is usually 

specified as heat release rate per unit area and is assigned to a surface. 

Once the reaction and heat release rate are defined, fuel is released from the surface, mixes with air, 

and reacts to form combustion products (including heat). A longer (but still brief) introduction to fire 

modeling is given in the Room Fire example. 

 

Figure 1. Burner fire in this example 
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This tutorial demonstrates how to: 

 Create a burner fire. 

 Add a thermocouple. 

 Add a slice plane for temperature visualization. 

 View 3D results using Smokeview. 

 View 2D results using PyroSim. 

The FDS input file listing is provided at the end of this document. You can import this directly into 

PyroSim. 

Select SI Units 
To select SI units: 

1. On the View menu, click Units and select SI to display values using the metric system. 

Create the Mesh 
In this example we will use mesh cells that are 0.1 m across. This value is somewhat smaller than 1/5 of 

the characteristic diameter (D*) for a 500 kW fire. As a rule of thumb, recommended cell sizes range 

from 1/5 to 1/20 of D* to ensure at least a moderate level of accuracy in modeling the plume 

(McGrattan, Kevin, et al. 2014). Using mesh cells that are smaller by a factor of 2 should decrease error 

by a factor of 4, but will increase the simulation run time by a factor of 16. 

1. On the Model menu, click Edit Meshes. 

2. Click New. 

3. Click OK to create the mesh. 

4. In the Min X box, type –1 and in the Max X box, type 1. 

5. In the Min Y box, type –1 and in the Max Y box, type 1. 

6. In the Min Z box, type 0 and in the Max Z box, type 3. 

7. In the X Cells box, type 20. 

8. In the Y Cells box, type 20. 

9. In the Z Cells box, type 30. 

10. Click OK to save changes and close the Edit Meshes dialog. 

11. On the View menu, click Fill View to resize the image. 
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Figure 2. Creating the mesh 

Define the Reaction 
For simulations that include combustion, the user must define a reaction. 

1. On the Model menu, click Edit Reactions. 

2. Click Add From Library. 

3. Select the POLYURETHANE_GM27 reaction and add it to the current model.  

4. Click Close. 

5. Click OK to close the Edit Reactions dialog. 

Create the Fire Surface 
Surfaces are used to define the properties of objects in your FDS model. In this example, we define a 

burner (fire) surface that releases heat at a rate of 1000 kW/m2. 

1. On the Model menu, click Edit Surfaces. 
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2. Click New. 

3. In the Surface Name box, type Fire, Figure 3. 

4. In the Surface Type list, select Burner. 

5. Click OK to create the new burner surface. 

6. Click OK to save changes and close the Edit Surfaces dialog. 

 

Figure 3. Inserting a new burner surface 

 

Figure 4. Default parameters for the burner surface 
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Create the Fire 
Now that we define the fire location in our model. In this example, we will first create an obstruction 

and then place the fire (defined by a vent) on the obstruction. If the fire covered an entire side of the 

obstruction, we could just assign the fire surface to the obstruction and not use a vent. If the fire was on 

a model boundary, we could just use a vent and not include an obstruction.  

First we create the obstruction: 

1. On the Model menu, click New Obstruction. 

2. In the ID box, type Fire Obstruction. 

3. Click on the Geometry tab. 

4. In the Min X box, type –.5 and in the Max X box, type .5. 

5. In the Min Y box, type –.5 and in the Max Y box, type .5. 

6. In the Min Z box, type 0 and in the Max Z box, type .2. 

7. Click OK to create the new obstruction. 

Note that we have made sure that the geometry of the obstruction corresponds to the cell size of 0.1 m. 

This removes any uncertainty as to what dimensions the obstruction will snap to. Also, all surfaces of the 

obstruction are the default inert boundary condition. 

Now we will define the fire on one half of the top surface of the obstruction. Recall that FDS broadly 

uses the term “vent” to reference any 2D surface used to apply boundary conditions on a rectangular 

patch. Our vent will have a surface area of 0.5 m2, so the total heat release rate will be 500 kW. 

1. On the Model menu, click New Vent. 

2. In the ID box, type Fire Vent, Figure 5. 

3. In the Surface list, select Fire. This specifies that the previously created burner surface will 

define the properties of the vent. 

4. Click on the Geometry tab. In the Plane list, select Z and in the location box type .2. 

5. In the Min X box, type 0 and in the Max X box, type .5 (recall that the vent covers only half the 

top surface). 

6. In the Min Y box, type –.5 and in the Max Y box, type .5. 

7. Click OK to create the new burner vent. 
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Figure 5. Creating the burner vent 

Open Sides and Top of the Mesh 
We want the sides and top of the mesh to be open boundaries. This is accomplished by creating open 

surfaces on these boundaries. PyroSim can automatically do this for all the boundaries of a mesh. 

1. In the Tree view, right-click Mesh01 and click Open Mesh Boundaries. This will create six new 

open vents on all sides of the mesh. 

2. Since we want the bottom to be closed, select the vent Mesh Vent: Mesh01 [ZMIN] and delete 

it. 
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Figure 6: Create open mesh boundaries 

Add a Thermocouple 
1. On the Devices menu, click New Thermocouple. 

2. In the Device Name box, type Thermocouple at 1.5 m. 

3. On the Location row, in the Z box, type 1.5. 

4. Click OK to create the thermocouple. It will appear as a yellow dot in the center of the model. 

5. On the toolbar, click the Show Labels button to toggle the labels on and off. 

Add Slice Planes (Contour planes) 
1. On the Output menu, click Slices. 

2. In the XYZ Plane column, click the input cell and select Y. 

3. In the Plane Value column, click the cell and type 0. 

4. In the Gas Phase Quantity column, click the cell and select Temperature. 

5. In the Use Vector? column, click the cell and select NO. 

6. Click OK to create the slice plane. 

7. Repeat, but this time plot Velocity and select YES for vectors. 

8. Repeat, but this time in the Gas Phase Quantity column, click and scroll to the top of the list. 

Select [Species Quantity], then for Quantity select Volume Fraction and for Species select Air. 

Click OK. Select NO for vectors. Press the ENTER key for a new line. 

9. Repeat so that you are plotting the Volume Fraction of AIR, PRODUCTS, and REAC_FUEL. This 

will show us where the reaction is occurring. Air is supplied from the open boundaries, fuel is 

supplied by the fire surface, and products are the result of combustion. See Figure 7. 

10. On the toolbar, click the Show Slices button to toggle the slice planes on and off. 
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Figure 7: Defining the slice plane plots. 

Rotate the Model for a Better View 
1. To reset the zoom and properly center the model, press CTRL+R. PyroSim will now be looking 

straight down at the model along the Z axis. 

2. Press the left mouse button in the 3D View and drag to rotate the model.  In Figure 8, the 

burner is shown in red and the thermocouple as a yellow dot. The slice plane is semi-

transparent and the open vents are blue. 
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Figure 8. The Burner Fire model 

Save the Model 
1. On the File menu, click Save. 

2. Choose a location to save the model (usually a new folder). For this example, we will create a 

Burner folder and name the file burner. 

3. Click OK to save the model. 

Run the Simulation 
1. On the FDS menu, click Run FDS. 

2. The FDS Simulation dialog will appear and display the progress of the simulation. By default, 

PyroSim specifies an end time of 10 seconds. When the simulation is complete, Smokeview will 

start and display a 3D still image of the model. 

View Smoke in 3D 
1. In the Smokeview window, right-click to activate the menu. 

2. In the menu, click Load/Unload > 3D Smoke > SOOT MASS FRACTION. 
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3. In the menu, click Load/Unload > 3D Smoke > HRRPUV. This is the heat release rate per unit 

volume and is an indication of the location of the combustion reaction. 

4. In the menu, click Load/Unload > Vector Slices > Velocity > Y=0. 

5. This will start an animation of the smoke, HRRPUV, and velocity vectors. This is a busy plot, but it 

does show many details of the fire. The polyurethane reaction results in very dense smoke. 

 

Figure 9: A plot of smoke, the heat release rate per unit volume, and velocity vectors. 

Quick Aside Smokeview Controls 
Smokeview is developed by NIST, so some of the controls are different than PyroSim. 

1. To rotate in Smokeview, click and drag the mouse. 

2. To zoom and pan horizontally in Smokeview, press the CTRL key and drag up/down (for zoom) 

or left/right (for horizontal pan). 

3. To pan vertically in Smokeview, press the ALT key, click the mouse, and drag up/down.  

4. To view a specific time in the animation, click the timeline bar in the bottom of the Smokeview 

window. To return to animation mode, press t. 
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5. To clear the display in Smokeview, right-click to activate the menu, then click Load/Unload > 

Unload All. 

6. Right-click and select Help for more hints. 

Air, Fuel, and Products Contours 
At any location, the volume fractions of air, fuel, and products will sum to 1. Contours of these 

quantities are shown in Figure 10. Air is most of the volume fraction for most of the model. The fuel is 

released from the fire surface and the products result from mixing of the fuel and air.  

    
a. Air b. Fuel c. Products  

Figure 10: Contours of the air, fuel, and products volume fractions. Blue corresponds to zero and red 

to 1. 

As a mechanical engineer, I initially assumed (incorrectly) that the heat release rate was just a simple 

heat source, not a fuel vapor. I did not understand that if we specify heat release rate and combustion, 

the simulated fire will vary with time, depending on the mixing and ventilation. In fact, if the mesh 

boundaries are not large enough, the unburned fuel vapor will be carried out of the model bounds and 

the model heat release rate will never reach the specified value. 
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Figure 11: Calculated heat release rate. This is obtained by integrating the heat release rate per unit 

volume over the model domain. The specified HRR was 500 kW (1000 kW/m2*0.5 m2). The calculated 

HRR varies with time as the fuel mixes with the air and results in combustion. 

View Temperature Measurements 
The output of the devices such as thermocouples can be plotted: 

1. In the PyroSim window, on the FDS menu, click Plot Time History Results. 

2. A dialog will appear showing the different types of 2D results that are available. Select 

burner_devc.csv and click Open to view the temperature device output. 
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Figure 12. Temperature time history plot 
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FDS Input File 
Following is a listing of the FDS input file. You can either save this as a text file and import into PyroSim, 

or you can: 

1. Open PyroSim and on the File menu, click New. 

2. Select and copy the entire listing below. 

3. On the PyroSim Edit menu, click Paste. You will receive a warning that Simulation Parameters 

already exists in the model, click Yes to All to replace all existing data with the FDS file data. 

4. Click the Reset tool. 

5. Save and run. 

Paste is great, but please work through the example.  

burner.fds 

Generated by PyroSim - Version 2015.4.1117 

Nov 17, 2015 2:21:33 PM 

 

&HEAD CHID='burner'/ 

&TIME T_END=10.0/ 

&DUMP RENDER_FILE='burner.ge1', COLUMN_DUMP_LIMIT=.TRUE., DT_RESTART=300.0/ 

 

&MESH ID='Mesh01', IJK=20,20,30, XB=-1.0,1.0,-1.0,1.0,0.0,3.0/ 

 

&REAC ID='POLYURETHANE_GM27', 

      FYI='SFPE Handbook, GM27', 

      FUEL='REAC_FUEL', 

      C=1.0, 

      H=1.7, 

      O=0.3, 

      N=0.08, 

      CO_YIELD=0.042, 

      SOOT_YIELD=0.198/ 

 

&DEVC ID='Thermocouple at 1.4 m', QUANTITY='THERMOCOUPLE', XYZ=0.0,0.0,1.5/ 

&SURF ID='Fire', 

      COLOR='RED', 

      HRRPUA=1000.0/ 

 

&OBST XB=-0.5,0.5,-0.5,0.5,0.0,0.2, SURF_ID='INERT'/ Fire Obstruction 

 

&VENT SURF_ID='OPEN', XB=1.0,1.0,-1.0,1.0,0.0,3.0/ Mesh Vent: Mesh01 [XMAX] 

&VENT SURF_ID='OPEN', XB=-1.0,-1.0,-1.0,1.0,0.0,3.0/ Mesh Vent: Mesh01 [XMIN] 

&VENT SURF_ID='OPEN', XB=-1.0,1.0,1.0,1.0,0.0,3.0/ Mesh Vent: Mesh01 [YMAX] 

&VENT SURF_ID='OPEN', XB=-1.0,1.0,-1.0,-1.0,0.0,3.0/ Mesh Vent: Mesh01 [YMIN] 

&VENT SURF_ID='OPEN', XB=-1.0,1.0,-1.0,1.0,3.0,3.0/ Mesh Vent: Mesh01 [ZMAX] 

&VENT SURF_ID='Fire', XB=0.0,0.5,-0.5,0.5,0.2,0.2/ Fire Vent 

 

&SLCF QUANTITY='TEMPERATURE', PBY=0.0/ 

&SLCF QUANTITY='VELOCITY', VECTOR=.TRUE., PBY=0.0/ 

&SLCF QUANTITY='VOLUME FRACTION', SPEC_ID='AIR', PBY=0.0/ 



 

 

 

&SLCF QUANTITY='VOLUME FRACTION', SPEC_ID='PRODUCTS', PBY=0.0/ 

&SLCF QUANTITY='VOLUME FRACTION', SPEC_ID='REAC_FUEL', PBY=0.0/ 

 

&TAIL / 

  


