TMVOC Buckley-Leverett Flow
# Table of Contents

1. Buckley-Leverett Flow
   - Description ................................................................................................................................. 1
   - Create a New Model ....................................................................................................................... 1
   - Default Units ............................................................................................................................... 1
   - Save the Model ............................................................................................................................. 2
   - Specify the Solution Mesh ............................................................................................................ 2
     - Global Properties ......................................................................................................................... 2
     - Edit VOC Data ............................................................................................................................ 2
     - Change CHEMP.6 Data ............................................................................................................... 3
     - Change CHEMP.7 Data ............................................................................................................... 3
     - Change CHEMP.8 Data ............................................................................................................... 3
     - Change CHEMP.9 Data ............................................................................................................... 4
     - Add to Active VOC List .............................................................................................................. 4
   - Material Properties ...................................................................................................................... 4
     - Define Additional Material Data ............................................................................................... 5
   - Initial Conditions .......................................................................................................................... 5
   - Edit Mesh ...................................................................................................................................... 5
   - Solution Controls .......................................................................................................................... 7
   - Output Controls ............................................................................................................................ 8
   - Save and Run ................................................................................................................................. 8
   - View Results ................................................................................................................................. 8
   - View Cell Time History Plots ....................................................................................................... 9
Disclaimer

Thunderhead Engineering makes no warranty, expressed or implied, to users of PetraSim, and accepts no responsibility for its use. Users of PetraSim assume sole responsibility under Federal law for determining the appropriateness of its use in any particular application; for any conclusions drawn from the results of its use; and for any actions taken or not taken as a result of analyses performed using these tools.

Users are warned that PetraSim is intended for use only by those competent in the field of multi-phase, multi-component fluid flow in porous and fractured media. PetraSim is intended only to supplement the informed judgment of the qualified user. The software package is a computer model that may or may not have predictive capability when applied to a specific set of factual circumstances. Lack of accurate predictions by the model could lead to erroneous conclusions. All results should be evaluated by an informed user.

Throughout this document, the mention of computer hardware or commercial software does not constitute endorsement by Thunderhead Engineering, nor does it indicate that the products are necessarily those best suited for the intended purpose.
1. Buckley-Leverett Flow

Description
This example is Problem No. 2 (*rblm*) - "1-D Buckley-Leverett Flow" - as described in "TMVOC, A Numerical Simulator for Three-Phase Non-Isothermal Flows of Multicomponent Hydrocarbon Mixtures in Saturated-Unsaturated Heterogeneous Media", Pruess and Battistelli, LBNL-49375, 2002.

The geometry of the problem is given below. A horizontal column, 304.8 m long is divided into 40 elements. The column is filled with an initial mixture of NAPL and water. Water is injected at one end and, at the other end, a single cell is used to define a constant boundary condition.

![Figure 1.1: Problem geometry](image)

Create a New Model
1. On the File menu, click New.
2. For both the Simulator Mode and EOS choose TMVOC.
3. For the Model Bounds enter the coordinates as shown in Table 1.1.
4. Click OK.

<table>
<thead>
<tr>
<th>Axis</th>
<th>Min (m)</th>
<th>Max (m)</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>0.0</td>
<td>304.8</td>
</tr>
<tr>
<td>Y</td>
<td>0.0</td>
<td>1.0</td>
</tr>
<tr>
<td>Z</td>
<td>-1.0</td>
<td>0.0</td>
</tr>
</tbody>
</table>

Default Units
By default, PetraSim uses the TOUGH2 metric unit system (for example, the TOUGH2 system specifies permeability in units of m²). We will use the default system. To change the default units:

1. On the View menu, click Unit System.
2. Select the units you wish to use for each parameter.
Note that even if using the default TOUGH2 system, you can enter values in any of the optional units supported by PetraSim. For example, you can type **10 years** for time or **5 mD** for permeability. PetraSim will convert to the units being used in the model.

**Save the Model**
It is good practice to save the model initially. Some of the files created by TOUGH have the same name for every simulation, so it is good practice to create a separate folder for simulation.

To save your model:

1. On the **File** menu, click **Save**.
2. Create a new folder named **TMVOC Prob 2** and in the **File Name** box, type **TMVOC_prob2**.
3. Click **Save**.

**Specify the Solution Mesh**
For this simulation, we only want one cell in the (Z) direction. This is the default value, so we do not need to edit this value in the layers. However, we do need to define the mesh in the X and Y directions:

1. On the **Model** menu, click **Create Mesh**.
2. In the **X Cells** box, type **40**.
3. In the **Y Cells** box, type **1**.
4. Click **OK** to create the mesh.

**Global Properties**
1. On the **Properties** menu, click **Global Properties**.
2. In the **Name** box, type **TMVOC Problem 2**.
3. Click the **EOS** TAB.
4. Select the **Isothermal Mode** check box.
5. Click the **Edit Options** button to edit thermophysical options.
6. In the **Air Solubility Correlation** list, select **K_H=10^{10} (Pa) Independent of Temperature**.
7. Click **OK** to close the **Thermophysical Properties** dialog.

**Edit VOC Data**
The VOC (NAPL) used in this example is not chemically active, so it is necessary to create a new VOC with some modifications. Note: When you create a new VOC, the data is saved to the voc.dat file usually located in the C:\ProgramData\PetraSim folder.

To create a new VOC:

1. Click the **Edit VOC Data** button.
2. Click **New**.
3. In the **Name** box, type **Chlorobenzene Modified**.
4. In the **Based On** list, select **Chlorobenzene (STD)**.
5. Click OK. If you receive a message that the name **Chlorobenzene Modified** is already being used, then do not create a new VOC. Instead, cancel and open the existing **Chlorobenzene Modified** to edit the input data.

**Change CHEMP.6 Data**

1. Click the **CHEMP.6** tab near the top of the **Edit VOC Data** dialog.
2. In the **Reference Density for NAPL** box, type **998.3**.
3. In the **Reference Temperature for NAPL** box, type **292.15**.
4. In the **Reference Binary Diffusivity of VOC in Air** box, type **8.0E-6**.
5. In the **Reference Temperature for Gas Diffusivity** box, type **273.15**.
6. In the **Chemical Diffusivity Exponent** box, type **1.0**.

![Edit VOC Data](image)

**Figure 1.2: Edit CHEMP.6 Data**

**Change CHEMP.7 Data**

1. Click the **CHEMP.7** tab.
2. In the **VLOA** box, type **0.0**.
3. In the **VLOB** box, type **0.0**.
4. In the **VLOC** box, type **1.0**.
5. In the **VLOD** box, type **292.15**.

**Change CHEMP.8 Data**

1. Click the **CHEMP.8** tab.
2. In the **SOLA** box, type **1.06E-7**.
Change CHEMP.9 Data
1. Click the CHEMP.9 tab.
2. In the Chemical Organic Carbon Partition Coef. Box, type 0.0.
3. In the Default Fraction of Organic Compound in Soil box, type 0.0.
4. Click OK to close the Edit VOC Data dialog.

Add to Active VOC List
1. Select Chlorobenzene Modified in the VOC Library list.
2. Click the right arrow (-->) to move the selection to the Active Simulation VOCs list.
3. Click OK to close the Global Properties dialog.

![Figure 1.3: Global Properties](image)

Material Properties
2. In the Name box, type DIRT1.
3. In the Porosity box, type 0.2.
5. In the Wet Heat Conductivity box, type 3.1.
Define Additional Material Data
1. Click the Additional Material Data button.
2. In the Relative Permeability box, select Faust (1985). The default properties are correct.
3. Click the Misc tab.
4. In the Pore Compressibility box, type 1.0E-8.
5. Click OK to close the Additional Material Data dialog.
6. Click OK to close the Material Data dialog.

Initial Conditions
1. On the Properties menu, click Initial Conditions.
2. In the Phase list, select 6 - Water and NAPL.
3. In the Pressure box, type 6.895E5.
4. In the Temperature box, type 19.0.
5. In the Water Saturation box, type 0.159.
6. In the Mole Fraction box for Chlorobenzene Modified, type 1.0.
7. Click OK.

Figure 1.4: Initial Conditions

Edit Mesh
To make it easier to work with this 1D problem, you can scale the Y or Z axes. To scale the Y axis:

1. On the View menu, click Scale Axes.
2. In the Y Factor box, type 10.
3. Click OK.

At X=0, water is injected at a constant rate of 150.6E-6 kg/s. To name this cell, specify the water injection, and mark the cell for additional time history output:

1. Click to select the left-most cell (or search for cell 1 in the Find box).
2. On the Edit menu, click Properties.
3. In the Cell Name box, type Injection.
4. Click the Sources/Sinks tab.
5. In the Available Components list, select Water/Steam.
6. Select the Component is a Source check box.
7. In the Rate box, type 1.506E-04.
8. In the Enthalpy box, type 8.0E4.
9. Click the Print Options tab.
10. Select the Print Time Dependent Flow and Generation (BC) Data check box.
11. Click OK to exit out of the Edit Cell Data dialog.

![Figure 1.5: Edit Cell Data dialog](image)

At X=304.8, a fixed state is defined.

1. Click to select the right-most cell (or search for cell 40 in the Find box).
2. On the Edit menu, select Properties.
3. In the Cell Name box, type Fixed.
4. In the Type box, select Fixed State.
5. Click the Print Options tab.
6. Select the Print Time Dependent Flow and Generation (BC) Data check box.
7. Click OK to exit out of the Edit Cell Data dialog.

To generate additional time history output at the center cell:

1. Click to select a cell near the center (or search for cell 19 in the Find box).
2. On the Edit menu, click Properties.
3. In the Cell Name box, type Center.
4. Click the Print Options tab.
5. Select the Print Time Dependent Flow and Generation (BC) Data check box.
6. Click OK to exit out of the Edit Cell Data dialog.

Solution Controls

1. On the Analysis menu, click Solution Controls.
2. In the End Time box, type 1500 days.
3. In the Max Time Step dropdown, select User Defined.
4. In the Max Time Step box, type 10 days.
5. Click OK.
Output Controls

1. On the Analysis menu, click Output Controls.
2. In the Print and Plot Every # Steps box, type 20.
3. Click the Relative Permeability, Viscosity, and Enthalpies check box.
4. Click OK.

Save and Run

1. On the File menu, click Save.
2. On the Analysis menu, click Run TOUGH2.

View Results

You can view 3D results using the 3D Results dialog. To view 3D results, on the Results menu, click 3D Results. To scale the Z-axis for better visualization:

1. On the Results menu, click 3D Results.
2. On the View menu, click Scale Axes.
3. In the Y Factor box, type 50.0.
4. Click OK.

To show slice planes for oil saturation:
1. In the left-hand navigation pane, click **Slice Planes**.
2. In the **Axis** list, select **Z**.
3. In the **Coord** box, type **-0.5**.
4. Click **Close**.
5. In the **Time** list, select the last entry (1.296E08).
6. In the **Scalar** list, select **SO**.

![Figure 1.7: 3D Results](image)

When finished, you can close the 3D Results dialog.

**View Cell Time History Plots**

To view 2D time history plots for oil saturation:

1. On the **Results** menu, select **Cell History Plots**.
2. In the **Variable** list, select **Soil**.
3. In the **Cell Name** list, select **Center (19)**.
Figure 1.8: Time history plot of oil saturation in center cell

When finished, you can close the Cell Time History dialog.